diff mbox

Fix PR54782

Message ID CAO2gOZW+-7Q1aYBg230Q2ZcP=9_TBf9QSNWhMciEZOzezRbnbA@mail.gmail.com
State New
Headers show

Commit Message

Dehao Chen Oct. 3, 2012, 8:09 p.m. UTC
Thanks for the comments. The patch was updated as attached.

Dehao

On Wed, Oct 3, 2012 at 11:46 AM, Jakub Jelinek <jakub@redhat.com> wrote:
> On Wed, Oct 03, 2012 at 11:26:09AM -0700, Dehao Chen wrote:
>> @@ -6340,6 +6341,20 @@ move_block_to_fn (struct function *dest_cfun, basi
>>           SET_USE (use, replace_ssa_name (op, d->vars_map, dest_cfun->decl));
>>       }
>>
>> +      for (i = 0; i < EDGE_COUNT (bb->preds); i++)
>> +     {
>> +       location_t locus = gimple_phi_arg_location (phi, i);
>> +       if (locus != UNKNOWN_LOCATION)
>> +         {
>> +           tree block = LOCATION_BLOCK (locus);
>> +           if (d->orig_block == NULL_TREE
>                   || block == d->orig_block)
>> +             gimple_phi_arg_set_location (phi, i, d->new_block ?
>> +                 COMBINE_LOCATION_DATA (line_table, locus, d->new_block) :
>> +                 LOCATION_LOCUS (locus));
>> +         }
>> +     }
>> +
>
> The formatting is wrong on this.  ? and : would need to go to the next line
> and even the indentation of part of an argument is weird.
> IMHO better just do:
>               if (d->orig_block == NULL_TREE || block == d->orig_block)
>                 {
>                   if (d->new_block)
>                     locus = COMBINE_LOCATION_DATA (line_table, locus,
>                                                    d->new_block);
>                   else
>                     locus = LOCATION_LOCUS (locus);
>                   gimple_phi_arg_set_location (phi, i, locus);
>                 }
>
> It will be far more readable.
> And/or to decrease indentation level you could do
>           if (locus == UNKNOWN_LOCATION)
>             continue;
>           block = LOCATION_BLOCK (locus);
>           ...
>
>         Jakub

Comments

Jakub Jelinek Oct. 3, 2012, 8:21 p.m. UTC | #1
On Wed, Oct 03, 2012 at 01:09:27PM -0700, Dehao Chen wrote:
> Thanks for the comments. The patch was updated as attached.

Ok, thanks.

	Jakub
diff mbox

Patch

Index: gcc/tree-cfg.c
===================================================================
--- gcc/tree-cfg.c	(revision 192041)
+++ gcc/tree-cfg.c	(working copy)
@@ -6322,6 +6322,7 @@  move_block_to_fn (struct function *dest_cfun, basi
       use_operand_p use;
       tree op = PHI_RESULT (phi);
       ssa_op_iter oi;
+      unsigned i;
 
       if (virtual_operand_p (op))
 	{
@@ -6340,6 +6341,23 @@  move_block_to_fn (struct function *dest_cfun, basi
 	    SET_USE (use, replace_ssa_name (op, d->vars_map, dest_cfun->decl));
 	}
 
+      for (i = 0; i < EDGE_COUNT (bb->preds); i++)
+	{
+	  location_t locus = gimple_phi_arg_location (phi, i);
+	  tree block = LOCATION_BLOCK (locus);
+
+	  if (locus == UNKNOWN_LOCATION)
+	    continue;
+	  if (d->orig_block == NULL_TREE || block == d->orig_block)
+	    {
+	      if (d->new_block == NULL_TREE)
+		locus = LOCATION_LOCUS (locus);
+	      else
+		locus = COMBINE_LOCATION_DATA (line_table, locus, d->new_block);
+	      gimple_phi_arg_set_location (phi, i, locus);
+	    }
+	}
+
       gsi_next (&si);
     }
 
Index: gcc/testsuite/gcc.dg/pr54782.c
===================================================================
--- gcc/testsuite/gcc.dg/pr54782.c	(revision 0)
+++ gcc/testsuite/gcc.dg/pr54782.c	(revision 0)
@@ -0,0 +1,18 @@ 
+/* { dg-do compile } */
+/* { dg-options "-O -ffast-math -ftree-parallelize-loops=2 -g" } */
+
+struct S
+{
+  int n;
+  float *a;
+};
+
+int
+foo (struct S *s)
+{
+  float sum = 0;
+  int i;
+  for (i = 0; i < s->n; i++)
+    sum += s->a[i];
+  return sum;
+}