Patchwork Bump minimum gmp version to 4.2.3

login
register
mail settings
Submitter Diego Novillo
Date Sept. 6, 2012, 6:13 p.m.
Message ID <20120906181319.GA7169@google.com>
Download mbox | patch
Permalink /patch/182256/
State New
Headers show

Comments

Diego Novillo - Sept. 6, 2012, 6:13 p.m.
Doug was trying to build with gmp 4.2.1 and ran into this error:

gmp-4.2.1/include/gmp.h:515:12: error: 'std::FILE' has not been declared

This bug was fixed in gmp 4.2.3, so I've bumped the minimum
acceptable version in configure.ac

Tested on x86_64 with gmp 4.2.3.  Committed to trunk.


Diego.

    	* configure.ac: Bump minimum GMP version to 4.2.3.
	* configure: Re-generate.
NightStrike - Sept. 6, 2012, 7:13 p.m.
On Thu, Sep 6, 2012 at 2:13 PM, Diego Novillo <dnovillo@google.com> wrote:
> Doug was trying to build with gmp 4.2.1 and ran into this error:
>
> gmp-4.2.1/include/gmp.h:515:12: error: 'std::FILE' has not been declared
>
> This bug was fixed in gmp 4.2.3, so I've bumped the minimum
> acceptable version in configure.ac
>
> Tested on x86_64 with gmp 4.2.3.  Committed to trunk.

Don't you also have to modify the contrib/download_prerequisites
script, as well as the contents of
ftp://gcc.gnu.org/pub/gcc/infrastructure ?
NightStrike - Sept. 6, 2012, 7:16 p.m.
On Thu, Sep 6, 2012 at 3:13 PM, NightStrike <nightstrike@gmail.com> wrote:
> On Thu, Sep 6, 2012 at 2:13 PM, Diego Novillo <dnovillo@google.com> wrote:
>> Doug was trying to build with gmp 4.2.1 and ran into this error:
>>
>> gmp-4.2.1/include/gmp.h:515:12: error: 'std::FILE' has not been declared
>>
>> This bug was fixed in gmp 4.2.3, so I've bumped the minimum
>> acceptable version in configure.ac
>>
>> Tested on x86_64 with gmp 4.2.3.  Committed to trunk.
>
> Don't you also have to modify the contrib/download_prerequisites
> script, as well as the contents of
> ftp://gcc.gnu.org/pub/gcc/infrastructure ?

Actually, on closer inspection, other places list the minimum version
as 4.3.2, including:
http://gcc.gnu.org/install/prerequisites.html

as well as the two locations that I mention above.  Perhaps configure
should do likewise.
Diego Novillo - Sept. 6, 2012, 8:12 p.m.
On 2012-09-06 15:13 , NightStrike wrote:
> On Thu, Sep 6, 2012 at 2:13 PM, Diego Novillo <dnovillo@google.com> wrote:
>> Doug was trying to build with gmp 4.2.1 and ran into this error:
>>
>> gmp-4.2.1/include/gmp.h:515:12: error: 'std::FILE' has not been declared
>>
>> This bug was fixed in gmp 4.2.3, so I've bumped the minimum
>> acceptable version in configure.ac
>>
>> Tested on x86_64 with gmp 4.2.3.  Committed to trunk.
>
> Don't you also have to modify the contrib/download_prerequisites
> script, as well as the contents of
> ftp://gcc.gnu.org/pub/gcc/infrastructure ?

No. The version I changed is the minimum *tolerable* version (the one 
configure declares as buggy but usable).

4.3.2 is still the minimum we require as acceptable.


Diego.
Diego Novillo - Sept. 6, 2012, 8:13 p.m.
On 2012-09-06 15:16 , NightStrike wrote:

> Actually, on closer inspection, other places list the minimum version
> as 4.3.2, including:
> http://gcc.gnu.org/install/prerequisites.html
>
> as well as the two locations that I mention above.  Perhaps configure
> should do likewise.

It already does (configure.ac:1367).


Diego.

Patch

diff --git a/configure b/configure
index 8272ed0..a5df0c8 100755
--- a/configure
+++ b/configure
@@ -5318,7 +5318,7 @@  main ()
 
   #define GCC_GMP_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
   #define GCC_GMP_VERSION GCC_GMP_VERSION_NUM(__GNU_MP_VERSION,__GNU_MP_VERSION_MINOR,__GNU_MP_VERSION_PATCHLEVEL)
-  #if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,2,0)
+  #if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,2,3)
   choke me
   #endif
 
diff --git a/configure.ac b/configure.ac
index 36830d1..a6f5828 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1358,7 +1358,7 @@  if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
   AC_TRY_COMPILE([#include "gmp.h"],[
   #define GCC_GMP_VERSION_NUM(a,b,c) (((a) << 16L) | ((b) << 8) | (c))
   #define GCC_GMP_VERSION GCC_GMP_VERSION_NUM(__GNU_MP_VERSION,__GNU_MP_VERSION_MINOR,__GNU_MP_VERSION_PATCHLEVEL)
-  #if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,2,0)
+  #if GCC_GMP_VERSION < GCC_GMP_VERSION_NUM(4,2,3)
   choke me
   #endif
   ], [AC_TRY_COMPILE([#include <gmp.h>],[