Patchwork uclibc: depend on gcc_intermediate rather than $(gcc_intermediate)

login
register
mail settings
Submitter Raúl Sánchez Siles
Date Sept. 6, 2012, 4:11 p.m.
Message ID <201209061811.07607.rasasi78@gmail.com>
Download mbox | patch
Permalink /patch/182244/
State Not Applicable
Headers show

Comments

Raúl Sánchez Siles - Sept. 6, 2012, 4:11 p.m.
gcc_intermediate correctly manages GCC_HOST_PREREQ, unlike $(gcc_intermediate)
which fails due to unsatisfied dependencies.

Signed-off-by: Raúl Sánchez Siles <rasasi78@gmail.com>
---
 toolchain/uClibc/uclibc.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 534550a..3113f2f 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -496,7 +496,7 @@  UCLIBC_TARGETS+=uclibc-test
 endif
 endif
 
-uclibc: $(gcc_intermediate) $(STAGING_DIR)/usr/lib/libc.a $(UCLIBC_TARGETS)
+uclibc: gcc_intermediate $(STAGING_DIR)/usr/lib/libc.a $(UCLIBC_TARGETS)
 
 uclibc-source: $(DL_DIR)/$(UCLIBC_SOURCE)