diff mbox

[uq/master] kvm: Clean up irqfd API

Message ID 5031FB9C.4050803@siemens.com
State New
Headers show

Commit Message

Jan Kiszka Aug. 20, 2012, 8:55 a.m. UTC
No need to expose the fd-based interface, everyone will already be fine
with the more handy EventNotifier variant. Rename the latter to clarify
that we are still talking about irqfds here.

Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
---

Alex, please update your vfio patch accordingly.

 hw/virtio-pci.c |    4 ++--
 kvm-all.c       |   18 ++++--------------
 kvm-stub.c      |   14 ++------------
 kvm.h           |    6 ++----
 4 files changed, 10 insertions(+), 32 deletions(-)

Comments

Alex Williamson Aug. 21, 2012, 2:40 a.m. UTC | #1
On Mon, 2012-08-20 at 10:55 +0200, Jan Kiszka wrote:
> No need to expose the fd-based interface, everyone will already be fine
> with the more handy EventNotifier variant. Rename the latter to clarify
> that we are still talking about irqfds here.
> 
> Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
> ---
> 
> Alex, please update your vfio patch accordingly.

Sure, thanks for the heads up.

Acked-by: Alex Williamson <alex.williamson@redhat.com>

> 
>  hw/virtio-pci.c |    4 ++--
>  kvm-all.c       |   18 ++++--------------
>  kvm-stub.c      |   14 ++------------
>  kvm.h           |    6 ++----
>  4 files changed, 10 insertions(+), 32 deletions(-)
> 
> diff --git a/hw/virtio-pci.c b/hw/virtio-pci.c
> index 5e6e09e..40ea7df 100644
> --- a/hw/virtio-pci.c
> +++ b/hw/virtio-pci.c
> @@ -515,7 +515,7 @@ static int kvm_virtio_pci_vq_vector_use(VirtIOPCIProxy *proxy,
>      }
>      irqfd->users++;
>  
> -    ret = kvm_irqchip_add_irq_notifier(kvm_state, n, irqfd->virq);
> +    ret = kvm_irqchip_add_irqfd_notifier(kvm_state, n, irqfd->virq);
>      if (ret < 0) {
>          if (--irqfd->users == 0) {
>              kvm_irqchip_release_virq(kvm_state, irqfd->virq);
> @@ -536,7 +536,7 @@ static void kvm_virtio_pci_vq_vector_release(VirtIOPCIProxy *proxy,
>      VirtIOIRQFD *irqfd = &proxy->vector_irqfd[vector];
>      int ret;
>  
> -    ret = kvm_irqchip_remove_irq_notifier(kvm_state, n, irqfd->virq);
> +    ret = kvm_irqchip_remove_irqfd_notifier(kvm_state, n, irqfd->virq);
>      assert(ret == 0);
>  
>      if (--irqfd->users == 0) {
> diff --git a/kvm-all.c b/kvm-all.c
> index 34b02c1..fb02354 100644
> --- a/kvm-all.c
> +++ b/kvm-all.c
> @@ -1162,24 +1162,14 @@ static int kvm_irqchip_assign_irqfd(KVMState *s, int fd, int virq, bool assign)
>  }
>  #endif /* !KVM_CAP_IRQ_ROUTING */
>  
> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq)
> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
>  {
> -    return kvm_irqchip_assign_irqfd(s, fd, virq, true);
> +    return kvm_irqchip_assign_irqfd(s, event_notifier_get_fd(n), virq, true);
>  }
>  
> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq)
> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
>  {
> -    return kvm_irqchip_add_irqfd(s, event_notifier_get_fd(n), virq);
> -}
> -
> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq)
> -{
> -    return kvm_irqchip_assign_irqfd(s, fd, virq, false);
> -}
> -
> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq)
> -{
> -    return kvm_irqchip_remove_irqfd(s, event_notifier_get_fd(n), virq);
> +    return kvm_irqchip_assign_irqfd(s, event_notifier_get_fd(n), virq, false);
>  }
>  
>  static int kvm_irqchip_create(KVMState *s)
> diff --git a/kvm-stub.c b/kvm-stub.c
> index 94c9ea1..3c52eb5 100644
> --- a/kvm-stub.c
> +++ b/kvm-stub.c
> @@ -141,22 +141,12 @@ void kvm_irqchip_release_virq(KVMState *s, int virq)
>  {
>  }
>  
> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq)
> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
>  {
>      return -ENOSYS;
>  }
>  
> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq)
> -{
> -    return -ENOSYS;
> -}
> -
> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq)
> -{
> -    return -ENOSYS;
> -}
> -
> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq)
> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
>  {
>      return -ENOSYS;
>  }
> diff --git a/kvm.h b/kvm.h
> index 5b8f588..37d1f81 100644
> --- a/kvm.h
> +++ b/kvm.h
> @@ -272,8 +272,6 @@ int kvm_set_ioeventfd_pio_word(int fd, uint16_t adr, uint16_t val, bool assign);
>  int kvm_irqchip_add_msi_route(KVMState *s, MSIMessage msg);
>  void kvm_irqchip_release_virq(KVMState *s, int virq);
>  
> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
>  #endif
Avi Kivity Sept. 9, 2012, 2:01 p.m. UTC | #2
On 08/20/2012 11:55 AM, Jan Kiszka wrote:
> No need to expose the fd-based interface, everyone will already be fine
> with the more handy EventNotifier variant. Rename the latter to clarify
> that we are still talking about irqfds here.

Thanks, applied.

>  
> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq);
> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
>  #endif

Those names aren't particularly satisfying.  add_irqfd_notifier implies
you want to be notified about irqfd events, but that's not what the
function does.  Not sure what a good name would be.
Jan Kiszka Sept. 10, 2012, 9:27 a.m. UTC | #3
On 2012-09-09 16:01, Avi Kivity wrote:
> On 08/20/2012 11:55 AM, Jan Kiszka wrote:
>> No need to expose the fd-based interface, everyone will already be fine
>> with the more handy EventNotifier variant. Rename the latter to clarify
>> that we are still talking about irqfds here.
> 
> Thanks, applied.
> 
>>  
>> -int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq);
>> -int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq);
>> -int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq);
>> -int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq);
>> +int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
>> +int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
>>  #endif
> 
> Those names aren't particularly satisfying.  add_irqfd_notifier implies
> you want to be notified about irqfd events, but that's not what the
> function does.  Not sure what a good name would be.

Now that there are no more variants, we could also drop the "notifier"
from the name again. Better?

Jan
diff mbox

Patch

diff --git a/hw/virtio-pci.c b/hw/virtio-pci.c
index 5e6e09e..40ea7df 100644
--- a/hw/virtio-pci.c
+++ b/hw/virtio-pci.c
@@ -515,7 +515,7 @@  static int kvm_virtio_pci_vq_vector_use(VirtIOPCIProxy *proxy,
     }
     irqfd->users++;
 
-    ret = kvm_irqchip_add_irq_notifier(kvm_state, n, irqfd->virq);
+    ret = kvm_irqchip_add_irqfd_notifier(kvm_state, n, irqfd->virq);
     if (ret < 0) {
         if (--irqfd->users == 0) {
             kvm_irqchip_release_virq(kvm_state, irqfd->virq);
@@ -536,7 +536,7 @@  static void kvm_virtio_pci_vq_vector_release(VirtIOPCIProxy *proxy,
     VirtIOIRQFD *irqfd = &proxy->vector_irqfd[vector];
     int ret;
 
-    ret = kvm_irqchip_remove_irq_notifier(kvm_state, n, irqfd->virq);
+    ret = kvm_irqchip_remove_irqfd_notifier(kvm_state, n, irqfd->virq);
     assert(ret == 0);
 
     if (--irqfd->users == 0) {
diff --git a/kvm-all.c b/kvm-all.c
index 34b02c1..fb02354 100644
--- a/kvm-all.c
+++ b/kvm-all.c
@@ -1162,24 +1162,14 @@  static int kvm_irqchip_assign_irqfd(KVMState *s, int fd, int virq, bool assign)
 }
 #endif /* !KVM_CAP_IRQ_ROUTING */
 
-int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq)
+int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
 {
-    return kvm_irqchip_assign_irqfd(s, fd, virq, true);
+    return kvm_irqchip_assign_irqfd(s, event_notifier_get_fd(n), virq, true);
 }
 
-int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq)
+int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
 {
-    return kvm_irqchip_add_irqfd(s, event_notifier_get_fd(n), virq);
-}
-
-int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq)
-{
-    return kvm_irqchip_assign_irqfd(s, fd, virq, false);
-}
-
-int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq)
-{
-    return kvm_irqchip_remove_irqfd(s, event_notifier_get_fd(n), virq);
+    return kvm_irqchip_assign_irqfd(s, event_notifier_get_fd(n), virq, false);
 }
 
 static int kvm_irqchip_create(KVMState *s)
diff --git a/kvm-stub.c b/kvm-stub.c
index 94c9ea1..3c52eb5 100644
--- a/kvm-stub.c
+++ b/kvm-stub.c
@@ -141,22 +141,12 @@  void kvm_irqchip_release_virq(KVMState *s, int virq)
 {
 }
 
-int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq)
+int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
 {
     return -ENOSYS;
 }
 
-int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq)
-{
-    return -ENOSYS;
-}
-
-int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq)
-{
-    return -ENOSYS;
-}
-
-int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq)
+int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq)
 {
     return -ENOSYS;
 }
diff --git a/kvm.h b/kvm.h
index 5b8f588..37d1f81 100644
--- a/kvm.h
+++ b/kvm.h
@@ -272,8 +272,6 @@  int kvm_set_ioeventfd_pio_word(int fd, uint16_t adr, uint16_t val, bool assign);
 int kvm_irqchip_add_msi_route(KVMState *s, MSIMessage msg);
 void kvm_irqchip_release_virq(KVMState *s, int virq);
 
-int kvm_irqchip_add_irqfd(KVMState *s, int fd, int virq);
-int kvm_irqchip_remove_irqfd(KVMState *s, int fd, int virq);
-int kvm_irqchip_add_irq_notifier(KVMState *s, EventNotifier *n, int virq);
-int kvm_irqchip_remove_irq_notifier(KVMState *s, EventNotifier *n, int virq);
+int kvm_irqchip_add_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
+int kvm_irqchip_remove_irqfd_notifier(KVMState *s, EventNotifier *n, int virq);
 #endif