Patchwork 2.6.28-git4 - powerpc - drivers build fails with !CONFIG_VIOPATH

login
register
mail settings
Submitter Kamalesh Babulal
Date Jan. 6, 2009, 9:38 a.m.
Message ID <20090106093847.GB5066@linux.vnet.ibm.com>
Download mbox | patch
Permalink /patch/16789/
State Superseded, archived
Headers show

Comments

Kamalesh Babulal - Jan. 6, 2009, 9:38 a.m.
* Sam Ravnborg <sam@ravnborg.org> [2009-01-06 08:31:49]:

> > 
> > 	Sorry for resending the patch before taking care of the response. Resending 
> > the patch with changes made to other three drivers also.
> > 
> > Impact: Fix the VIOPATH dependency in the iSeries dependent drivers.
> > 
> > iSeries depend drivers build fails, when CONFIG_VIOPATH is disabled.
> > Removing the dependency of VIOPATH by selecting it, when the drivers
> > dependent on iSeries code.
> > 
> > 
> > Signed-off-by: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
> > ---
> >  arch/powerpc/platforms/iseries/Kconfig |    5 ++++-
> >  drivers/char/Kconfig                   |    1 +
> >  drivers/scsi/Kconfig                   |    1 +
> >  3 files changed, 6 insertions(+), 1 deletions(-)
> > 
> > diff --git a/arch/powerpc/platforms/iseries/Kconfig b/arch/powerpc/platforms/iseries/Kconfig
> > index ed3753d..5cb2320 100644
> > --- a/arch/powerpc/platforms/iseries/Kconfig
> > +++ b/arch/powerpc/platforms/iseries/Kconfig
> > @@ -10,18 +10,21 @@ menu "iSeries device drivers"
> >  config VIODASD


<snip>

> 
> VIOPATH is set using select so the "depends on" is effectively ignored.
> If you think you need the "depends on" then you need to revisit the
> symbol that will select VIOPATH and make sure _they_ have this dependency.
> 
> 	Sam

Hi Sam,

	VIOPATH is used only by the PPC_ISERIES code. The symbols selecting
the VIOPATH are also dependent on the PPC_ISERIES. Should we make the 
config VIOPATH as default n, because it being selected the dependent
drivers.

Impact: Fix the VIOPATH dependency in the iSeries dependent drivers.

iSeries depend drivers build fails, when CONFIG_VIOPATH is disabled.
Removing the dependency of VIOPATH by selecting it, when the drivers
dependent on iSeries code.

Signed-off-by: Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
---
 arch/powerpc/platforms/iseries/Kconfig |    6 ++++--
 drivers/char/Kconfig                   |    1 +
 drivers/scsi/Kconfig                   |    1 +
 3 files changed, 6 insertions(+), 2 deletions(-)
Sam Ravnborg - Jan. 6, 2009, 10:46 a.m.
Hi Kamalesh

Looks good, small nit below.

>  config VIOPATH
>  	bool
> -	depends on VIODASD || VIOCD || VIOTAPE || ISERIES_VETH
> -	default y
> +	default n

As 'n' is default anyway this line is not needed and I suggest you
spin a final version of the patch with this removed.

	Sam

Patch

diff --git a/arch/powerpc/platforms/iseries/Kconfig b/arch/powerpc/platforms/iseries/Kconfig
index ed3753d..fd524cd 100644
--- a/arch/powerpc/platforms/iseries/Kconfig
+++ b/arch/powerpc/platforms/iseries/Kconfig
@@ -10,18 +10,21 @@  menu "iSeries device drivers"
 config VIODASD
 	tristate "iSeries Virtual I/O disk support"
 	depends on BLOCK
+	select VIOPATH
 	help
 	  If you are running on an iSeries system and you want to use
 	  virtual disks created and managed by OS/400, say Y.
 
 config VIOCD
 	tristate "iSeries Virtual I/O CD support"
+	select VIOPATH
 	help
 	  If you are running Linux on an IBM iSeries system and you want to
 	  read a CD drive owned by OS/400, say Y here.
 
 config VIOTAPE
 	tristate "iSeries Virtual Tape Support"
+	select VIOPATH
 	help
 	  If you are running Linux on an iSeries system and you want Linux
 	  to read and/or write a tape drive owned by OS/400, say Y here.
@@ -30,5 +33,4 @@  endmenu
 
 config VIOPATH
 	bool
-	depends on VIODASD || VIOCD || VIOTAPE || ISERIES_VETH
-	default y
+	default n
diff --git a/drivers/char/Kconfig b/drivers/char/Kconfig
index 1697043..b8da09a 100644
--- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig
@@ -616,6 +616,7 @@  config HVC_ISERIES
 	default y
 	select HVC_DRIVER
 	select HVC_IRQ
+	select VIOPATH
 	help
 	  iSeries machines support a hypervisor virtual console.
 
diff --git a/drivers/scsi/Kconfig b/drivers/scsi/Kconfig
index b732297..256c7be 100644
--- a/drivers/scsi/Kconfig
+++ b/drivers/scsi/Kconfig
@@ -884,6 +884,7 @@  config SCSI_IBMVSCSI
 	tristate "IBM Virtual SCSI support"
 	depends on PPC_PSERIES || PPC_ISERIES
 	select SCSI_SRP_ATTRS
+	select VIOPATH if PPC_ISERIES
 	help
 	  This is the IBM POWER Virtual SCSI Client