Patchwork [06/11] acpi_table_add(): rename 'qemu_len' to 'newlen'

login
register
mail settings
Submitter Eduardo Habkost
Date June 27, 2012, 8:23 p.m.
Message ID <1340828587-15201-7-git-send-email-ehabkost@redhat.com>
Download mbox | patch
Permalink /patch/167745/
State New
Headers show

Comments

Eduardo Habkost - June 27, 2012, 8:23 p.m.
Now there's only one "length of the new table" variable inside acpi_table_add()
(acpi_len is now inside acpi_make_table_header()), so name it "newlen" instead
of "qemu_len".

This change looks pointless by itself, but it should make the code
clearer after changing the rest of the code handling
acpi_tables/acpi_tables_len.

(Yes, I could have introduced 'qemu_len' as 'newlen' directly, but I
like to keep the code during intermediate refactoring steps clear as
well, and 'newlen' would be a confusing name when 'qemu_len' was
introduced).

No behavior change, just a variable rename.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
 hw/acpi.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Patch

diff --git a/hw/acpi.c b/hw/acpi.c
index 16e2065..e69b37a 100644
--- a/hw/acpi.c
+++ b/hw/acpi.c
@@ -190,7 +190,7 @@  int acpi_table_add(const char *t)
 {
     char buf[1024], *f;
     size_t start, allen;
-    size_t qemu_len;
+    size_t newlen; /* length of the new table */
     bool has_header;
     int r;
 
@@ -254,9 +254,9 @@  int acpi_table_add(const char *t)
     f = acpi_tables + start;   /* start of the table */
 
     /* length of the whole table, including our prefix */
-    qemu_len = allen - start;
+    newlen = allen - start;
 
-    if (acpi_make_table_header(t, has_header, f, qemu_len) < 0) {
+    if (acpi_make_table_header(t, has_header, f, newlen) < 0) {
         return -1;
     }