From patchwork Tue Jun 5 15:11:59 2012 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Artem Bityutskiy X-Patchwork-Id: 163096 Return-Path: X-Original-To: incoming@patchwork.ozlabs.org Delivered-To: patchwork-incoming@bilbo.ozlabs.org Received: from merlin.infradead.org (merlin.infradead.org [IPv6:2001:4978:20e::2]) (using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTPS id 9D4B9B6EEC for ; Wed, 6 Jun 2012 01:12:20 +1000 (EST) Received: from localhost ([::1] helo=merlin.infradead.org) by merlin.infradead.org with esmtp (Exim 4.76 #1 (Red Hat Linux)) id 1SbvPa-0004LA-21; Tue, 05 Jun 2012 15:11:10 +0000 Received: from mga09.intel.com ([134.134.136.24]) by merlin.infradead.org with esmtp (Exim 4.76 #1 (Red Hat Linux)) id 1SbvPH-0004HA-GW for linux-mtd@lists.infradead.org; Tue, 05 Jun 2012 15:10:52 +0000 Received: from orsmga002.jf.intel.com ([10.7.209.21]) by orsmga102.jf.intel.com with ESMTP; 05 Jun 2012 08:10:50 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="4.67,351,1309762800"; d="scan'208";a="153188589" Received: from blue.fi.intel.com ([10.237.72.50]) by orsmga002.jf.intel.com with ESMTP; 05 Jun 2012 08:10:49 -0700 From: Artem Bityutskiy To: Richard Weinberger Subject: [PATCH 5/5] UBI: fastmap: more tiny TODOs Date: Tue, 5 Jun 2012 18:11:59 +0300 Message-Id: <1338909119-5188-6-git-send-email-dedekind1@gmail.com> X-Mailer: git-send-email 1.7.10 In-Reply-To: <1338909119-5188-1-git-send-email-dedekind1@gmail.com> References: <1338909119-5188-1-git-send-email-dedekind1@gmail.com> X-Spam-Note: CRM114 invocation failed X-Spam-Score: -5.0 (-----) X-Spam-Report: SpamAssassin version 3.3.2 on merlin.infradead.org summary: Content analysis details: (-5.0 points) pts rule name description ---- ---------------------- -------------------------------------------------- -5.0 RCVD_IN_DNSWL_HI RBL: Sender listed at http://www.dnswl.org/, high trust [134.134.136.24 listed in list.dnswl.org] 0.0 FREEMAIL_FROM Sender email is commonly abused enduser mail provider (dedekind1[at]gmail.com) 0.0 DKIM_ADSP_CUSTOM_MED No valid author signature, adsp_override is CUSTOM_MED 0.8 SPF_NEUTRAL SPF: sender does not match SPF record (neutral) 0.2 FREEMAIL_ENVFROM_END_DIGIT Envelope-from freemail username ends in digit (dedekind1[at]gmail.com) -1.9 BAYES_00 BODY: Bayes spam probability is 0 to 1% [score: 0.0000] 0.9 NML_ADSP_CUSTOM_MED ADSP custom_med hit, and not from a mailing list Cc: MTD Maling List , Shmulik Ladkani X-BeenThere: linux-mtd@lists.infradead.org X-Mailman-Version: 2.1.14 Precedence: list List-Id: Linux MTD discussion mailing list List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , MIME-Version: 1.0 Sender: linux-mtd-bounces@lists.infradead.org Errors-To: linux-mtd-bounces+incoming=patchwork.ozlabs.org@lists.infradead.org From: Artem Bityutskiy Signed-off-by: Artem Bityutskiy --- TODO | 2 ++ drivers/mtd/ubi/fastmap.c | 7 +++++++ 2 files changed, 9 insertions(+) diff --git a/TODO b/TODO index 17e30b6..a944159 100644 --- a/TODO +++ b/TODO @@ -9,3 +9,5 @@ to the ubi-utils.git repository, to a separate branch at the beginning test UBI + fastmap with it. 3. Test the autoresize feature 4. Test 'ubi_flush()' +5. Test that the same UBI image works fine on both LE and BE machines. I guess + we can do this using sime kind of emulators? diff --git a/drivers/mtd/ubi/fastmap.c b/drivers/mtd/ubi/fastmap.c index f938507..d446fc3 100644 --- a/drivers/mtd/ubi/fastmap.c +++ b/drivers/mtd/ubi/fastmap.c @@ -455,6 +455,9 @@ out: * @fm_raw: the fastmap it self as byte array * @fm_size: size of the fastmap in bytes */ +/* TODO: please, make all pointers like 'fm_raw' of type void. It is indeed a + * pointer to data blob, it is not a pointer to a string of characters. Note, + * that in pointer arithmetics void * is the same as char *. */ static int ubi_attach_fastmap(struct ubi_device *ubi, struct ubi_attach_info *ai, char *fm_raw, size_t fm_size) @@ -503,6 +506,10 @@ static int ubi_attach_fastmap(struct ubi_device *ubi, if (fm_pos >= fm_size) goto fail_bad; + /* TODO: this is difficult to read. Can we please have instead an + * aggregate data structure? I did not think hard on it may be you have + * a good reason for this difficult style, but on the first glance it + * does not look like. And where are all the endiness stuff? */ fmhdr = (struct ubi_fm_hdr *)(fm_raw + fm_pos); fm_pos += sizeof(*fmhdr); if (fm_pos >= fm_size)