diff mbox

[ARM] rename thumb_unexpanded_epilogue to thumb1_unexpanded_epilogue

Message ID 000901cd2239$10e7a830$32b6f890$@Yorsh@arm.com
State New
Headers show

Commit Message

Greta Yorsh April 24, 2012, 4:41 p.m. UTC
Rename thumb_unexpanded_epilogue to thumb1_unexpanded_epilogue.

In preparation for epilogue generation in RTL and anyway it's the right name
for this function.

Ok for trunk?

Thanks,
Greta

gcc/ChangeLog

2012-04-24  Ian Bolton  <ian.bolton at arm.com>
            Sameera Deshpande  <sameera.deshpande at arm.com>
            Greta Yorsh  <greta.yorsh at arm.com>

        * config/arm/arm-protos.h (thumb_unexpanded_epilogue): Rename to...
        (thumb1_unexpanded_epilogue): ...this.
        * config/arm/arm.c (thumb_unexpanded_epilogue): Rename to...
        (thumb1_unexpanded_epilogue): ...this.
        * config/arm/arm.md (thumb_unexpanded_epilogue): Rename to...
        (thumb1_unexpanded_epilogue): ...this.

Comments

Greta Yorsh May 1, 2012, 12:45 p.m. UTC | #1
Ping!
http://gcc.gnu.org/ml/gcc-patches/2012-04/msg01485.html

Thanks,
Greta

> -----Original Message-----
> From: Greta Yorsh [mailto:Greta.Yorsh@arm.com]
> Sent: 24 April 2012 17:41
> To: gcc-patches@gcc.gnu.org
> Cc: paul@codesourcery.com; Ramana Radhakrishnan; Richard Earnshaw;
> nickc@redhat.com
> Subject: [Patch, ARM] rename thumb_unexpanded_epilogue to
> thumb1_unexpanded_epilogue
> 
> Rename thumb_unexpanded_epilogue to thumb1_unexpanded_epilogue.
> 
> In preparation for epilogue generation in RTL and anyway it's the right
> name
> for this function.
> 
> Ok for trunk?
> 
> Thanks,
> Greta
> 
> gcc/ChangeLog
> 
> 2012-04-24  Ian Bolton  <ian.bolton at arm.com>
>             Sameera Deshpande  <sameera.deshpande at arm.com>
>             Greta Yorsh  <greta.yorsh at arm.com>
> 
>         * config/arm/arm-protos.h (thumb_unexpanded_epilogue): Rename
> to...
>         (thumb1_unexpanded_epilogue): ...this.
>         * config/arm/arm.c (thumb_unexpanded_epilogue): Rename to...
>         (thumb1_unexpanded_epilogue): ...this.
>         * config/arm/arm.md (thumb_unexpanded_epilogue): Rename to...
>         (thumb1_unexpanded_epilogue): ...this.
Richard Earnshaw May 1, 2012, 1:55 p.m. UTC | #2
On 24/04/12 17:41, Greta Yorsh wrote:
> Rename thumb_unexpanded_epilogue to thumb1_unexpanded_epilogue.
> 
> In preparation for epilogue generation in RTL and anyway it's the right name
> for this function.
> 
> Ok for trunk?
> 
> Thanks,
> Greta

OK.

R.

> 
> gcc/ChangeLog
> 
> 2012-04-24  Ian Bolton  <ian.bolton at arm.com>
>             Sameera Deshpande  <sameera.deshpande at arm.com>
>             Greta Yorsh  <greta.yorsh at arm.com>
> 
>         * config/arm/arm-protos.h (thumb_unexpanded_epilogue): Rename to...
>         (thumb1_unexpanded_epilogue): ...this.
>         * config/arm/arm.c (thumb_unexpanded_epilogue): Rename to...
>         (thumb1_unexpanded_epilogue): ...this.
>         * config/arm/arm.md (thumb_unexpanded_epilogue): Rename to...
>         (thumb1_unexpanded_epilogue): ...this.
diff mbox

Patch

diff --git a/gcc/config/arm/arm-protos.h b/gcc/config/arm/arm-protos.h
index 21a89aa..0c4bb96 100644
--- a/gcc/config/arm/arm-protos.h
+++ b/gcc/config/arm/arm-protos.h
@@ -178,7 +178,7 @@  extern int arm_float_words_big_endian (void);
 
 /* Thumb functions.  */
 extern void arm_init_expanders (void);
-extern const char *thumb_unexpanded_epilogue (void);
+extern const char *thumb1_unexpanded_epilogue (void);
 extern void thumb1_expand_prologue (void);
 extern void thumb1_expand_epilogue (void);
 extern const char *thumb1_output_interwork (void);
diff --git a/gcc/config/arm/arm.c b/gcc/config/arm/arm.c
index 5d9cbc5..0b7f3c8 100644
--- a/gcc/config/arm/arm.c
+++ b/gcc/config/arm/arm.c
@@ -22032,7 +22032,7 @@  thumb1_extra_regs_pushed (arm_stack_offsets *offsets, bool for_prologue)
 
 /* The bits which aren't usefully expanded as rtl.  */
 const char *
-thumb_unexpanded_epilogue (void)
+thumb1_unexpanded_epilogue (void)
 {
   arm_stack_offsets *offsets;
   int regno;
diff --git a/gcc/config/arm/arm.md b/gcc/config/arm/arm.md
index 4f6d965..ed33c9b 100644
--- a/gcc/config/arm/arm.md
+++ b/gcc/config/arm/arm.md
@@ -10673,7 +10673,7 @@ 
   if (TARGET_32BIT)
     return arm_output_epilogue (NULL);
   else /* TARGET_THUMB1 */
-    return thumb_unexpanded_epilogue ();
+    return thumb1_unexpanded_epilogue ();
   "
   ; Length is absolute worst case
   [(set_attr "length" "44")