diff mbox

[06/11] enic: replace open-coded ARRAY_SIZE with macro

Message ID 1334105769-9235-1-git-send-email-jim.cromie@gmail.com
State Accepted, archived
Delegated to: David Miller
Headers show

Commit Message

Jim Cromie April 11, 2012, 12:56 a.m. UTC
Signed-off-by: Jim Cromie <jim.cromie@gmail.com>
---
 drivers/net/ethernet/cisco/enic/enic_pp.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

David Miller April 13, 2012, 5:15 p.m. UTC | #1
From: Jim Cromie <jim.cromie@gmail.com>
Date: Tue, 10 Apr 2012 18:56:09 -0600

> Signed-off-by: Jim Cromie <jim.cromie@gmail.com>

Applied.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/net/ethernet/cisco/enic/enic_pp.c b/drivers/net/ethernet/cisco/enic/enic_pp.c
index dafea1e..43464f0 100644
--- a/drivers/net/ethernet/cisco/enic/enic_pp.c
+++ b/drivers/net/ethernet/cisco/enic/enic_pp.c
@@ -184,7 +184,7 @@  static int (*enic_pp_handlers[])(struct enic *enic, int vf,
 };
 
 static const int enic_pp_handlers_count =
-			sizeof(enic_pp_handlers)/sizeof(*enic_pp_handlers);
+			ARRAY_SIZE(enic_pp_handlers);
 
 static int enic_pp_preassociate(struct enic *enic, int vf,
 	struct enic_port_profile *prev_pp, int *restore_pp)