Patchwork [PATCHv3] Error out when tls-channel option is used without TLS

login
register
mail settings
Submitter Christophe Fergeau
Date Feb. 24, 2012, 5:28 p.m.
Message ID <1330104512-14738-1-git-send-email-cfergeau@redhat.com>
Download mbox | patch
Permalink /patch/142956/
State New
Headers show

Comments

Christophe Fergeau - Feb. 24, 2012, 5:28 p.m.
It's currently possible to setup spice channels using TLS when
no TLS port has been specified (ie TLS is disabled). This cannot
work, so better to error out in such a situation.
---
 ui/spice-core.c |    8 +++++++-
 1 files changed, 7 insertions(+), 1 deletions(-)
Gerd Hoffmann - Feb. 24, 2012, 5:32 p.m.
On 02/24/12 18:28, Christophe Fergeau wrote:
> It's currently possible to setup spice channels using TLS when
> no TLS port has been specified (ie TLS is disabled). This cannot
> work, so better to error out in such a situation.

Patch added to spice patch queue.

thanks,
  Gerd

Patch

diff --git a/ui/spice-core.c b/ui/spice-core.c
index a374999..9a7912a 100644
--- a/ui/spice-core.c
+++ b/ui/spice-core.c
@@ -526,6 +526,12 @@  static int add_channel(const char *name, const char *value, void *opaque)
     int rc;
 
     if (strcmp(name, "tls-channel") == 0) {
+        int *tls_port = opaque;
+        if (!*tls_port) {
+            error_report("spice: tried to setup tls-channel"
+                         " without specifying a TLS port");
+            exit(1);
+        }
         security = SPICE_CHANNEL_SECURITY_SSL;
     }
     if (strcmp(name, "plaintext-channel") == 0) {
@@ -697,7 +703,7 @@  void qemu_spice_init(void)
     spice_server_set_playback_compression
         (spice_server, qemu_opt_get_bool(opts, "playback-compression", 1));
 
-    qemu_opt_foreach(opts, add_channel, NULL, 0);
+    qemu_opt_foreach(opts, add_channel, &tls_port, 0);
 
     if (0 != spice_server_init(spice_server, &core_interface)) {
         error_report("failed to initialize spice server");