Patchwork [01/11] powerpc/85xx: Add 'fsl, pq3-gpio' compatiable for GPIO driver

login
register
mail settings
Submitter Kumar Gala
Date Nov. 10, 2011, 4:06 p.m.
Message ID <1320941229-29557-1-git-send-email-galak@kernel.crashing.org>
Download mbox | patch
Permalink /patch/124917/
State Superseded
Headers show

Comments

Kumar Gala - Nov. 10, 2011, 4:06 p.m.
Support MPC85xx platforms outside of MPC8572/MPC8536.  The
MPC8572/MPC8536 have an erratum that is worked around based on having
"fsl,mpc8572-gpio" in the compatiable list.  All other MPC85xx SoCs
don't require this workaround and thus utilize the 'fsl,pq3-gpio'
compatiable.

Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
---
 drivers/gpio/gpio-mpc8xxx.c |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)
Kumar Gala - Nov. 10, 2011, 4:15 p.m.
oops, sent the wrong set of patches, ignore this group.

- k

Patch

diff --git a/drivers/gpio/gpio-mpc8xxx.c b/drivers/gpio/gpio-mpc8xxx.c
index fb4963a..d74d19b 100644
--- a/drivers/gpio/gpio-mpc8xxx.c
+++ b/drivers/gpio/gpio-mpc8xxx.c
@@ -310,6 +310,7 @@  static struct of_device_id mpc8xxx_gpio_ids[] __initdata = {
 	{ .compatible = "fsl,mpc8572-gpio", },
 	{ .compatible = "fsl,mpc8610-gpio", },
 	{ .compatible = "fsl,mpc5121-gpio", .data = mpc512x_irq_set_type, },
+	{ .compatible = "fsl,pq3-gpio",     },
 	{ .compatible = "fsl,qoriq-gpio",   },
 	{}
 };