[v6,27/28] package/qt53d: Add optional dependency on qt5multimedia
diff mbox series

Message ID 20200217212350.29750-28-anaumann@ultratronik.de
State New
Headers show
Series
  • Qt5 qmake infra and per-package compatibility
Related show

Commit Message

Andreas Naumann Feb. 17, 2020, 9:23 p.m. UTC
The audio-visualizer-qml example depends on it.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
---
 package/qt5/qt53d/qt53d.mk | 4 ++++
 1 file changed, 4 insertions(+)

Patch
diff mbox series

diff --git a/package/qt5/qt53d/qt53d.mk b/package/qt5/qt53d/qt53d.mk
index eeb1b3644c..c9db7cd0d7 100644
--- a/package/qt5/qt53d/qt53d.mk
+++ b/package/qt5/qt53d/qt53d.mk
@@ -10,6 +10,10 @@  QT53D_SOURCE = qt3d-$(QT5_SOURCE_TARBALL_PREFIX)-$(QT53D_VERSION).tar.xz
 QT53D_DEPENDENCIES = qt5base qt5declarative
 QT53D_INSTALL_STAGING = YES
 
+ifeq ($(BR2_PACKAGE_QT5MULTIMEDIA),y)
+QT53D_DEPENDENCIES += qt5multimedia
+endif
+
 ifeq ($(BR2_PACKAGE_ASSIMP),y)
 QT53D_DEPENDENCIES += assimp
 endif