[focal] DKMS versioned provides redux
mbox series

Message ID 20200206135205.GA5631@brain
State New
Headers show
Series
  • [focal] DKMS versioned provides redux
Related show

Pull-request

https://git.launchpad.net/~apw/ubuntu/+source/linux-meta/+git/focal dkms-build--various-fixes-2

Message

Andy Whitcroft Feb. 6, 2020, 1:52 p.m. UTC
The previous DKMS series added versioned provides for the packaged DKMS
packages.  These are applied to the binary packages which carry the
actual binaries, however this makes these direct installation candidates
for those DKMS package which is not ideal.  Move them over to the meta
packages.  This also reduces the likelyhood a breaks clause would be
resolved by uninstalling your kernel binaries.

Pull requests for focal:linux{,-restricted-modules,-meta}-5.4 are at the
bottom of this email.  In large part this reverts off the linux support
as we will deliver this in meta and lrm.

Proposing for focal.

-apw

===
The following changes since commit 92fe35d883857059a08689d0637a3824a555e78e:

  Linux 5.4.17 (2020-02-04 09:18:51 +0000)

are available in the Git repository at:

  https://git.launchpad.net/~apw/ubuntu/+source/linux/+git/focal dkms-build--various-fixes-2

for you to fetch changes up to 7df92f0e2e1b2ea5ac3ef6a70f95878a637ba28d:

  UBUNTU: [Packaging] wireguard -- drop provides (2020-02-06 13:06:28 +0000)

----------------------------------------------------------------
  * installing linux-modules-nvidia does not remove nvidia-dkms, and the kernel
    prioritizes the wrong version of the module from disk (LP: #1856414)
    - Revert "UBUNTU: [Packaging] dkms -- switch basic provides to *-modules"
    - Revert "UBUNTU: [Packaging] dkms -- add Provides: specifiers for existing
      zfs/nvidia/vbox"
    - Revert "UBUNTU: [packaging] dkms-build -- include versioned provides"
    - [Packaging] wireguard -- drop provides

===
The following changes since commit 1b9ce36b8665c86cbd5649073684877395f883e4:

  UBUNTU: Ubuntu-5.4-5.4.0-13.16 (2020-01-30 16:57:36 +0100)

are available in the Git repository at:

  https://git.launchpad.net/~apw/ubuntu/+source/linux-restricted-modules/+git/focal dkms-build--various-fixes-2

for you to fetch changes up to 5fea132d78508d0e509d6d3146928480222140c9:

  UBUNTU: debian/scripts/dkms-build -- update from master (2020-02-06 13:45:09 +0000)

----------------------------------------------------------------
  * Packaging resync (LP: #1786013)
    - debian/scripts/dkms-build -- update from master

  * installing linux-modules-nvidia does not remove nvidia-dkms, and the kernel
    prioritizes the wrong version of the module from disk (LP: #1856414)
    - Revert "UBUNTU: [Packaging] dkms -- add Provides: specifiers for existing
      nvidia packages"
    - [Packaging] rules -- expose dkms provides data
    - [Config] expose provides information on meta packages

===
The following changes since commit c50595779fc712c2d045d145130264a3eac773ee:

  UBUNTU: Ubuntu-5.4-5.4.0.13.16 (2020-01-30 16:56:57 +0100)

are available in the Git repository at:

  https://git.launchpad.net/~apw/ubuntu/+source/linux-meta/+git/focal dkms-build--various-fixes-2

for you to fetch changes up to 5d9452f47d8f4764e9e0fab671ae12bffa32d1b3:

  UBUNTU: [Packaging] expose versioned provides for contained dkms binaries (2020-02-06 13:11:19 +0000)

----------------------------------------------------------------
  * installing linux-modules-nvidia does not remove nvidia-dkms, and the kernel
    prioritizes the wrong version of the module from disk (LP: #1856414)
    - [Packaging] update-version -- add dkms-versions data to sync list
    - [Packaging] expose versioned provides for contained dkms binaries

  * Packaging resync (LP: #1786013)
    - [Packaging] resync debian/dkms-versions from main package

Comments

Seth Forshee Feb. 6, 2020, 8:23 p.m. UTC | #1
On Thu, Feb 06, 2020 at 01:52:05PM +0000, Andy Whitcroft wrote:
> The previous DKMS series added versioned provides for the packaged DKMS
> packages.  These are applied to the binary packages which carry the
> actual binaries, however this makes these direct installation candidates
> for those DKMS package which is not ideal.  Move them over to the meta
> packages.  This also reduces the likelyhood a breaks clause would be
> resolved by uninstalling your kernel binaries.
> 
> Pull requests for focal:linux{,-restricted-modules,-meta}-5.4 are at the
> bottom of this email.  In large part this reverts off the linux support
> as we will deliver this in meta and lrm.
> 
> Proposing for focal.

Applied, thanks!