[FOCAL,master-next] autopkgtest: ensure a python2 interpreter is available.
diff mbox series

Message ID 20200114103112.259928-1-xnox@ubuntu.com
State New
Headers show
Series
  • [FOCAL,master-next] autopkgtest: ensure a python2 interpreter is available.
Related show

Commit Message

Dimitri John Ledkov Jan. 14, 2020, 10:31 a.m. UTC
python2 is replacing python package name in focal.

BugLink: https://bugs.launchpad.net/bugs/1858487

Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>
---
 debian/tests/control | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Seth Forshee Jan. 16, 2020, 5:07 p.m. UTC | #1
On Tue, Jan 14, 2020 at 10:31:12AM +0000, Dimitri John Ledkov wrote:
> python2 is replacing python package name in focal.
> 
> BugLink: https://bugs.launchpad.net/bugs/1858487
> 
> Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>

A similar patch has already been applied. Thanks!

Patch
diff mbox series

diff --git a/debian/tests/control b/debian/tests/control
index 4b80100ceb66..94eb9b9ed897 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -3,5 +3,5 @@  Depends: @builddeps@, fakeroot
 Restrictions: allow-stderr, skippable
 
 Tests: ubuntu-regression-suite
-Depends: build-essential, gcc-multilib [amd64 armhf i386], gdb, git, bzr
+Depends: build-essential, gcc-multilib [amd64 armhf i386], gdb, git, python2 | python, bzr
 Restrictions: allow-stderr, isolation-machine, breaks-testbed, skippable