mbox series

[GIT,PULL] gpio: updates for v5.6

Message ID 20200107120553.5620-1-brgl@bgdev.pl
State New
Headers show
Series [GIT,PULL] gpio: updates for v5.6 | expand

Pull-request

git://git.kernel.org/pub/scm/linux/kernel/git/brgl/linux.git tags/gpio-updates-for-v5.6-part1

Message

Bartosz Golaszewski Jan. 7, 2020, 12:05 p.m. UTC
From: Bartosz Golaszewski <bgolaszewski@baylibre.com>

Hi Linus,

as discussed: this is the PR that contains the cleanup patches submitted
as part of my series adding support for watching GPIO line status. Several
other patches picked up into my tree since the merge window are in here as
well.

Details are in the signed tag. Please pull.

Best regards,
Bartosz Golaszewski

The following changes since commit e42617b825f8073569da76dc4510bfa019b1c35a:

  Linux 5.5-rc1 (2019-12-08 14:57:55 -0800)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/brgl/linux.git tags/gpio-updates-for-v5.6-part1

for you to fetch changes up to 2a2cabd8bc1715ceceb9d9566055f4a0a8ff749a:

  gpiolib: use gpiochip_get_desc() in gpio_ioctl() (2020-01-07 12:03:28 +0100)

----------------------------------------------------------------
gpio updates for v5.6

- improvements in the gpio-pca953x driver
- use platform_irq_count() in gpio-mvebu and gpio-bcm-kona
- remove unneeded MODULE_VERSION() usage in the gpio directory
- irq-related improvements in gpio-tegra driver
- several improvements for the core subsystem code: fix confusing indentation,
  fix int type casting, unduplicate code in several places

----------------------------------------------------------------
Andy Shevchenko (1):
      gpio: pca953x: Remove redundant forward declaration

Bartosz Golaszewski (6):
      gpiolib: use 'unsigned int' instead of 'unsigned' in gpio_set_config()
      gpiolib: have a single place of calling set_config()
      gpiolib: convert the type of hwnum to unsigned int in gpiochip_get_desc()
      gpiolib: use gpiochip_get_desc() in linehandle_create()
      gpiolib: use gpiochip_get_desc() in lineevent_create()
      gpiolib: use gpiochip_get_desc() in gpio_ioctl()

Dmitry Osipenko (3):
      gpio: tegra: Use generic readl_relaxed/writel_relaxed accessors
      gpio: tegra: Properly handle irq_set_irq_wake() error
      gpio: tegra: Use NOIRQ phase for suspend/resume

Enrico Weigelt, metux IT consult (2):
      gpio: remove unneeded MODULE_VERSION() usage
      gpio: gpiolib: fix confusing indention

Peng Fan (2):
      gpio: mvebu: use platform_irq_count
      gpio: bcm-kona: use platform_irq_count

Vignesh Raghavendra (1):
      gpio: pca953x: Don't hardcode irq trigger type

 drivers/gpio/gpio-bcm-kona.c      | 12 +++++++---
 drivers/gpio/gpio-mvebu.c         |  7 ++++--
 drivers/gpio/gpio-pca953x.c       |  5 +---
 drivers/gpio/gpio-sama5d2-piobu.c |  1 -
 drivers/gpio/gpio-tb10x.c         |  1 -
 drivers/gpio/gpio-tegra.c         | 21 ++++++++--------
 drivers/gpio/gpiolib.c            | 50 +++++++++++++++++++++------------------
 drivers/gpio/gpiolib.h            |  3 ++-
 include/linux/gpio/driver.h       |  3 ++-
 9 files changed, 56 insertions(+), 47 deletions(-)

Comments

Linus Walleij Jan. 7, 2020, 12:54 p.m. UTC | #1
On Tue, Jan 7, 2020 at 1:05 PM Bartosz Golaszewski <brgl@bgdev.pl> wrote:

> as discussed: this is the PR that contains the cleanup patches submitted
> as part of my series adding support for watching GPIO line status. Several
> other patches picked up into my tree since the merge window are in here as
> well.

Pulled in, thanks a lot! Now it's time for the autobuilders to play with it.

Yours,
Linus Walleij