[PULL,0/2] Require Python >= 3.5 to build QEMU
mbox

Message ID 20191220165141.2207058-1-ehabkost@redhat.com
State New
Headers show

Pull-request

git://github.com/ehabkost/qemu.git tags/python-next-pull-request

Message

Eduardo Habkost Dec. 20, 2019, 4:51 p.m. UTC
Differences from the previous Python 3.5 pull request
that was rejected:

* Now tests/vm/netbsd was fixed
* .travis.yml is being updated to replace Python 3.4 job with 3.5

The following changes since commit f59b31e6d0c69792b5d817c5aa0a6ed64fba42e0:

  Merge remote-tracking branch 'remotes/stsquad/tags/pull-tesing-and-misc-191219-1' into staging (2019-12-20 14:00:49 +0000)

are available in the Git repository at:

  git://github.com/ehabkost/qemu.git tags/python-next-pull-request

for you to fetch changes up to ddf90699631db53c981b6a5a63d31c08e0eaeec7:

  configure: Require Python >= 3.5 (2019-12-20 13:45:59 -0300)

----------------------------------------------------------------
Require Python >= 3.5 to build QEMU

Python 2 EOL is 11 days away, we will stop supporting
it in QEMU 5.0.

----------------------------------------------------------------

Eduardo Habkost (2):
  travis: Replace Python 3.4 build with 3.5
  configure: Require Python >= 3.5

 .travis.yml            |  2 +-
 configure              | 18 ++++--------------
 tests/Makefile.include |  5 -----
 3 files changed, 5 insertions(+), 20 deletions(-)

Comments

Philippe Mathieu-Daudé Dec. 20, 2019, 4:53 p.m. UTC | #1
On 12/20/19 5:51 PM, Eduardo Habkost wrote:
> Differences from the previous Python 3.5 pull request
> that was rejected:
> 
> * Now tests/vm/netbsd was fixed
> * .travis.yml is being updated to replace Python 3.4 job with 3.5
> 
> The following changes since commit f59b31e6d0c69792b5d817c5aa0a6ed64fba42e0:
> 
>    Merge remote-tracking branch 'remotes/stsquad/tags/pull-tesing-and-misc-191219-1' into staging (2019-12-20 14:00:49 +0000)
> 
> are available in the Git repository at:
> 
>    git://github.com/ehabkost/qemu.git tags/python-next-pull-request
> 
> for you to fetch changes up to ddf90699631db53c981b6a5a63d31c08e0eaeec7:
> 
>    configure: Require Python >= 3.5 (2019-12-20 13:45:59 -0300)
> 
> ----------------------------------------------------------------
> Require Python >= 3.5 to build QEMU
> 
> Python 2 EOL is 11 days away, we will stop supporting
> it in QEMU 5.0.

That was quick! Thanks for sending it again today :)

> ----------------------------------------------------------------
> 
> Eduardo Habkost (2):
>    travis: Replace Python 3.4 build with 3.5
>    configure: Require Python >= 3.5
> 
>   .travis.yml            |  2 +-
>   configure              | 18 ++++--------------
>   tests/Makefile.include |  5 -----
>   3 files changed, 5 insertions(+), 20 deletions(-)
>
Peter Maydell Jan. 6, 2020, 2:07 p.m. UTC | #2
On Fri, 20 Dec 2019 at 16:51, Eduardo Habkost <ehabkost@redhat.com> wrote:
>
> Differences from the previous Python 3.5 pull request
> that was rejected:
>
> * Now tests/vm/netbsd was fixed
> * .travis.yml is being updated to replace Python 3.4 job with 3.5
>
> The following changes since commit f59b31e6d0c69792b5d817c5aa0a6ed64fba42e0:
>
>   Merge remote-tracking branch 'remotes/stsquad/tags/pull-tesing-and-misc-191219-1' into staging (2019-12-20 14:00:49 +0000)
>
> are available in the Git repository at:
>
>   git://github.com/ehabkost/qemu.git tags/python-next-pull-request
>
> for you to fetch changes up to ddf90699631db53c981b6a5a63d31c08e0eaeec7:
>
>   configure: Require Python >= 3.5 (2019-12-20 13:45:59 -0300)
>
> ----------------------------------------------------------------
> Require Python >= 3.5 to build QEMU
>
> Python 2 EOL is 11 days away, we will stop supporting
> it in QEMU 5.0.
>
> ---------------------------------------------------------------



Applied, thanks.

Please update the changelog at https://wiki.qemu.org/ChangeLog/5.0
for any user-visible changes.

-- PMM