doc: Correct `--enable-version-specific-runtime-libs' support information
diff mbox series

Message ID alpine.LFD.2.21.1911201550180.13542@redsun52.ssa.fujisawa.hgst.com
State Accepted
Headers show
Series
  • doc: Correct `--enable-version-specific-runtime-libs' support information
Related show

Commit Message

Maciej W. Rozycki Nov. 20, 2019, 4:03 p.m. UTC
The `--enable-version-specific-runtime-libs' configuration option is now 
supported throughout all of our target library subdirectories, so update 
installation documentation accordingly and also mention that the default 
for the option is `yes' for libada and `no' for the remaining libraries.

	gcc/
	* doc/install.texi (Options specification): Remove the list of 
	target library subdirectories supporting 
	`--enable-version-specific-runtime-libs'.  Document defaults for 
	the option.
---
 gcc/doc/install.texi |    4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

gcc-doc-version-specific-runtime-libs.diff

Comments

Maciej W. Rozycki Nov. 29, 2019, 9:25 a.m. UTC | #1
On Wed, 20 Nov 2019, Maciej W. Rozycki wrote:

> The `--enable-version-specific-runtime-libs' configuration option is now 
> supported throughout all of our target library subdirectories, so update 
> installation documentation accordingly and also mention that the default 
> for the option is `yes' for libada and `no' for the remaining libraries.

 Ping for:

<https://gcc.gnu.org/ml/gcc-patches/2019-11/msg01974.html>

  Maciej
Joseph Myers Nov. 29, 2019, 9:04 p.m. UTC | #2
On Fri, 29 Nov 2019, Maciej W. Rozycki wrote:

> On Wed, 20 Nov 2019, Maciej W. Rozycki wrote:
> 
> > The `--enable-version-specific-runtime-libs' configuration option is now 
> > supported throughout all of our target library subdirectories, so update 
> > installation documentation accordingly and also mention that the default 
> > for the option is `yes' for libada and `no' for the remaining libraries.
> 
>  Ping for:
> 
> <https://gcc.gnu.org/ml/gcc-patches/2019-11/msg01974.html>

This patch is OK.
Maciej W. Rozycki Nov. 30, 2019, 11:13 a.m. UTC | #3
On Fri, 29 Nov 2019, Joseph Myers wrote:

> > > The `--enable-version-specific-runtime-libs' configuration option is now 
> > > supported throughout all of our target library subdirectories, so update 
> > > installation documentation accordingly and also mention that the default 
> > > for the option is `yes' for libada and `no' for the remaining libraries.
> > 
> >  Ping for:
> > 
> > <https://gcc.gnu.org/ml/gcc-patches/2019-11/msg01974.html>
> 
> This patch is OK.

 Committed, thanks for your review.

  Maciej

Patch
diff mbox series

Index: gcc/gcc/doc/install.texi
===================================================================
--- gcc.orig/gcc/doc/install.texi
+++ gcc/gcc/doc/install.texi
@@ -1560,8 +1560,8 @@  addition, @samp{libstdc++}'s include fil
 @file{@var{libdir}} unless you overruled it by using
 @option{--with-gxx-include-dir=@var{dirname}}.  Using this option is
 particularly useful if you intend to use several versions of GCC in
-parallel.  This is currently supported by @samp{libgfortran},
-@samp{libstdc++}, and @samp{libobjc}.
+parallel.  The default is @samp{yes} for @samp{libada}, and @samp{no} for
+the remaining libraries.
 
 @item @anchor{WithAixSoname}--with-aix-soname=@samp{aix}, @samp{svr4} or @samp{both}
 Traditional AIX shared library versioning (versioned @code{Shared Object}