[2/2] configs/beaglebone: use the new BeagleBoard/BeagleBone kernel repository
diff mbox series

Message ID 20191102223839.16262-3-unixmania@gmail.com
State Accepted
Headers show
Series
  • configs/beaglebone: fix boot hang and update kernel
Related show

Commit Message

Carlos Santos Nov. 2, 2019, 10:38 p.m. UTC
From: Carlos Santos <unixmania@gmail.com>

The original source URL (http://beagleboard.org/source) now redirects to
https://elinux.org/Beagleboard:BeagleBoneBlack_Rebuilding_Software_Image
which points to an official kernel repository at GitHub.

There are updated RT and non-RT kernel source trees. Use the last non-RT
release (4.19.73-ti-r29) and the omap2plus defconfig.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
 configs/beaglebone_defconfig | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Nov. 8, 2019, 9:12 p.m. UTC | #1
Hello,

+Peter, who contributed the beagleboneai defconfig.

On Sat,  2 Nov 2019 19:38:39 -0300
unixmania@gmail.com wrote:

> From: Carlos Santos <unixmania@gmail.com>
> 
> The original source URL (http://beagleboard.org/source) now redirects to
> https://elinux.org/Beagleboard:BeagleBoneBlack_Rebuilding_Software_Image
> which points to an official kernel repository at GitHub.
> 
> There are updated RT and non-RT kernel source trees. Use the last non-RT
> release (4.19.73-ti-r29) and the omap2plus defconfig.
> 
> Signed-off-by: Carlos Santos <unixmania@gmail.com>

I've applied to next... but after doing, I realized that you could have
used the github macro, like we do in beagleboneai_defconfig. Could you
send a patch for that ?

Also, it would be nice if we could align beagleboneai, beaglebone and
beaglebone_qt5 to use the same U-Boot/Linux versions, if possible. I
see that the beagleboneai is using 4.14 even though it's a much newer
platform than beaglebone.

Thanks!

Thomas
Carlos Santos Nov. 8, 2019, 11:11 p.m. UTC | #2
On Fri, Nov 8, 2019 at 6:12 PM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello,
>
> +Peter, who contributed the beagleboneai defconfig.
>
> On Sat,  2 Nov 2019 19:38:39 -0300
> unixmania@gmail.com wrote:
>
> > From: Carlos Santos <unixmania@gmail.com>
> >
> > The original source URL (http://beagleboard.org/source) now redirects to
> > https://elinux.org/Beagleboard:BeagleBoneBlack_Rebuilding_Software_Image
> > which points to an official kernel repository at GitHub.
> >
> > There are updated RT and non-RT kernel source trees. Use the last non-RT
> > release (4.19.73-ti-r29) and the omap2plus defconfig.
> >
> > Signed-off-by: Carlos Santos <unixmania@gmail.com>
>
> I've applied to next... but after doing, I realized that you could have
> used the github macro, like we do in beagleboneai_defconfig. Could you
> send a patch for that ?

I kept using git download method but I can replace it by the download
or the tarbal from GitHub.

> Also, it would be nice if we could align beagleboneai, beaglebone and
> beaglebone_qt5 to use the same U-Boot/Linux versions, if possible. I
> see that the beagleboneai is using 4.14 even though it's a much newer
> platform than beaglebone.

I have been working on it but did not have much free time in the last
weeks. I will try to fix it on time for 2019.11.
Thomas Petazzoni Nov. 9, 2019, 2:19 p.m. UTC | #3
On Fri, 8 Nov 2019 20:11:14 -0300
Carlos Santos <unixmania@gmail.com> wrote:

> > I've applied to next... but after doing, I realized that you could have
> > used the github macro, like we do in beagleboneai_defconfig. Could you
> > send a patch for that ?  
> 
> I kept using git download method but I can replace it by the download
> or the tarbal from GitHub.

Yes, it's nicer to use the github macro, it saves a lot of download time.

> > Also, it would be nice if we could align beagleboneai, beaglebone and
> > beaglebone_qt5 to use the same U-Boot/Linux versions, if possible. I
> > see that the beagleboneai is using 4.14 even though it's a much newer
> > platform than beaglebone.  
> 
> I have been working on it but did not have much free time in the last
> weeks. I will try to fix it on time for 2019.11.

Sure, no problem. That was really a "nice to have" comment. Thanks!

Thomas

Patch
diff mbox series

diff --git a/configs/beaglebone_defconfig b/configs/beaglebone_defconfig
index ee97f80322..2de1bd0b32 100644
--- a/configs/beaglebone_defconfig
+++ b/configs/beaglebone_defconfig
@@ -7,8 +7,8 @@  BR2_ROOTFS_POST_IMAGE_SCRIPT="support/scripts/genimage.sh"
 BR2_ROOTFS_POST_SCRIPT_ARGS="-c board/beaglebone/genimage.cfg"
 BR2_LINUX_KERNEL=y
 BR2_LINUX_KERNEL_CUSTOM_GIT=y
-BR2_LINUX_KERNEL_CUSTOM_REPO_URL="git://git.ti.com/processor-sdk/processor-sdk-linux.git"
-BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="4dae378bbe721277b08699d1d88ffae12acc9b09"
+BR2_LINUX_KERNEL_CUSTOM_REPO_URL="git://github.com/beagleboard/linux.git"
+BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION="4.19.73-ti-r29"
 BR2_LINUX_KERNEL_DEFCONFIG="omap2plus"
 BR2_LINUX_KERNEL_DTS_SUPPORT=y
 BR2_LINUX_KERNEL_INTREE_DTS_NAME="am335x-evm am335x-bone am335x-boneblack am335x-bonegreen am335x-evmsk am335x-boneblue"