[OpenWrt-Devel] ath79: use nand_do_upgrade for nand subtarget
diff mbox series

Message ID 20191027231741.7252-1-freifunk@adrianschmutzler.de
State Accepted
Headers show
Series
  • [OpenWrt-Devel] ath79: use nand_do_upgrade for nand subtarget
Related show

Commit Message

Adrian Schmutzler Oct. 27, 2019, 11:17 p.m. UTC
On nand subtarget, the default upgrade mechanism should be
nand_do_upgrade. This patch changes platform_do_upgrade()
accordingly.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/ath79/nand/base-files/lib/upgrade/platform.sh | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Patch
diff mbox series

diff --git a/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh b/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
index 6f8c7d47ff..3956d5d73f 100644
--- a/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/nand/base-files/lib/upgrade/platform.sh
@@ -13,12 +13,11 @@  platform_do_upgrade() {
 	local board=$(board_name)
 
 	case "$board" in
-	aerohive,hiveap-121|\
-	zyxel,nbg6716)
-		nand_do_upgrade "$1"
+	glinet,gl-ar300m-nand)
+		default_do_upgrade "$1"
 		;;
 	*)
-		default_do_upgrade "$1"
+		nand_do_upgrade "$1"
 		;;
 	esac
 }