[1/1] package/python-asgiref: drop Python 2 support
diff mbox series

Message ID 20191020151126.2468-1-asafka7@gmail.com
State Accepted
Headers show
Series
  • [1/1] package/python-asgiref: drop Python 2 support
Related show

Commit Message

Asaf Kahlon Oct. 20, 2019, 3:11 p.m. UTC
Asgiref doesn't support Python 2 since version 2.0.0.
All the recursive reverse dependencies already support Python 3 only.

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
---
 package/python-asgiref/Config.in | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Oct. 21, 2019, 6:46 p.m. UTC | #1
On Sun, 20 Oct 2019 18:11:25 +0300
Asaf Kahlon <asafka7@gmail.com> wrote:

> Asgiref doesn't support Python 2 since version 2.0.0.
> All the recursive reverse dependencies already support Python 3 only.
> 
> Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
> ---
>  package/python-asgiref/Config.in | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas

Patch
diff mbox series

diff --git a/package/python-asgiref/Config.in b/package/python-asgiref/Config.in
index d0b816c369..71069bf48b 100644
--- a/package/python-asgiref/Config.in
+++ b/package/python-asgiref/Config.in
@@ -1,4 +1,5 @@ 
 config BR2_PACKAGE_PYTHON_ASGIREF
+	depends on BR2_PACKAGE_PYTHON3
 	bool "python-asgiref"
 	help
 	  ASGI is a standard for Python asynchronous web apps and