micropython: require python3 on the host
diff mbox series

Message ID 20191020082808.15908-1-judge.packham@gmail.com
State Accepted
Headers show
Series
  • micropython: require python3 on the host
Related show

Commit Message

Chris Packham Oct. 20, 2019, 8:28 a.m. UTC
There are some scripts used when building micropython that require
python3 on the build host. Use BR2_PYTHON3_HOST_DEPENDENCY so this can
be either be satisfied by installing it on the build host or by building
the host-python3 package.

Fixes:
- http://autobuild.buildroot.net/results/b85b2214576030026a8e04d142a77a2648379417/

Signed-off-by: Chris Packham <judge.packham@gmail.com>
---
 package/micropython/micropython.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Oct. 26, 2019, 10:35 a.m. UTC | #1
On Sun, 20 Oct 2019 21:28:08 +1300
Chris Packham <judge.packham@gmail.com> wrote:

> There are some scripts used when building micropython that require
> python3 on the build host. Use BR2_PYTHON3_HOST_DEPENDENCY so this can
> be either be satisfied by installing it on the build host or by building
> the host-python3 package.
> 
> Fixes:
> - http://autobuild.buildroot.net/results/b85b2214576030026a8e04d142a77a2648379417/
> 
> Signed-off-by: Chris Packham <judge.packham@gmail.com>
> ---
>  package/micropython/micropython.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas

Patch
diff mbox series

diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index 5824b4ab18..a5b8218d1f 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -8,7 +8,7 @@  MICROPYTHON_VERSION = 1.11
 MICROPYTHON_SITE = $(call github,micropython,micropython,v$(MICROPYTHON_VERSION))
 MICROPYTHON_LICENSE = MIT
 MICROPYTHON_LICENSE_FILES = LICENSE
-MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
+MICROPYTHON_DEPENDENCIES = host-pkgconf libffi $(BR2_PYTHON3_HOST_DEPENDENCY)
 
 # Set GIT_DIR so package won't use buildroot's version number
 MICROPYTHON_MAKE_ENV = \