diff mbox series

[05/11] qapi: add unplug primary event

Message ID 20191018202040.30349-6-jfreimann@redhat.com
State New
Headers show
Series add failover feature for assigned network devices | expand

Commit Message

Jens Freimann Oct. 18, 2019, 8:20 p.m. UTC
This event is emitted when we sent a request to unplug a
failover primary device from the Guest OS and it includes the
device id of the primary device.

Signed-off-by: Jens Freimann <jfreimann@redhat.com>
---
 qapi/migration.json | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Eric Blake Oct. 18, 2019, 8:28 p.m. UTC | #1
On 10/18/19 3:20 PM, Jens Freimann wrote:
> This event is emitted when we sent a request to unplug a
> failover primary device from the Guest OS and it includes the
> device id of the primary device.
> 
> Signed-off-by: Jens Freimann <jfreimann@redhat.com>
> ---
>   qapi/migration.json | 19 +++++++++++++++++++
>   1 file changed, 19 insertions(+)
> 
> diff --git a/qapi/migration.json b/qapi/migration.json
> index 82feb5bd39..52e69e2868 100644
> --- a/qapi/migration.json
> +++ b/qapi/migration.json
> @@ -1448,3 +1448,22 @@
>   # Since: 3.0
>   ##
>   { 'command': 'migrate-pause', 'allow-oob': true }
> +
> +##
> +# @UNPLUG_PRIMARY:
> +#
> +# Emitted from source side of a migration when migration state is
> +# WAIT_UNPLUG. Device was unplugged by guest operating system.
> +# Device resources in QEMU are kept on standby to be able to re-plug it in case
> +# of migration failure.
> +#
> +# @device_id: QEMU device id of the unplugged device
> +#
> +# Since: 4.2
> +#
> +# Example:
> +#   {"event": "UNPLUG_PRIMARY", "data": {"device_id": "hostdev0"} }

Unless there is a strong reason in favor of 'device_id' (such as 
consistency with a similar event), our naming convention prefers this to 
be 'device-id'.
Jens Freimann Oct. 21, 2019, 7:23 a.m. UTC | #2
On Fri, Oct 18, 2019 at 03:28:36PM -0500, Eric Blake wrote:
>On 10/18/19 3:20 PM, Jens Freimann wrote:
>>This event is emitted when we sent a request to unplug a
>>failover primary device from the Guest OS and it includes the
>>device id of the primary device.
>>
>>Signed-off-by: Jens Freimann <jfreimann@redhat.com>
>>---
>>  qapi/migration.json | 19 +++++++++++++++++++
>>  1 file changed, 19 insertions(+)
>>
>>diff --git a/qapi/migration.json b/qapi/migration.json
>>index 82feb5bd39..52e69e2868 100644
>>--- a/qapi/migration.json
>>+++ b/qapi/migration.json
>>@@ -1448,3 +1448,22 @@
>>  # Since: 3.0
>>  ##
>>  { 'command': 'migrate-pause', 'allow-oob': true }
>>+
>>+##
>>+# @UNPLUG_PRIMARY:
>>+#
>>+# Emitted from source side of a migration when migration state is
>>+# WAIT_UNPLUG. Device was unplugged by guest operating system.
>>+# Device resources in QEMU are kept on standby to be able to re-plug it in case
>>+# of migration failure.
>>+#
>>+# @device_id: QEMU device id of the unplugged device
>>+#
>>+# Since: 4.2
>>+#
>>+# Example:
>>+#   {"event": "UNPLUG_PRIMARY", "data": {"device_id": "hostdev0"} }
>
>Unless there is a strong reason in favor of 'device_id' (such as 
>consistency with a similar event), our naming convention prefers this 
>to be 'device-id'.

No reason, I'll change it.

Thanks Eric!

regards,
Jens
diff mbox series

Patch

diff --git a/qapi/migration.json b/qapi/migration.json
index 82feb5bd39..52e69e2868 100644
--- a/qapi/migration.json
+++ b/qapi/migration.json
@@ -1448,3 +1448,22 @@ 
 # Since: 3.0
 ##
 { 'command': 'migrate-pause', 'allow-oob': true }
+
+##
+# @UNPLUG_PRIMARY:
+#
+# Emitted from source side of a migration when migration state is
+# WAIT_UNPLUG. Device was unplugged by guest operating system.
+# Device resources in QEMU are kept on standby to be able to re-plug it in case
+# of migration failure.
+#
+# @device_id: QEMU device id of the unplugged device
+#
+# Since: 4.2
+#
+# Example:
+#   {"event": "UNPLUG_PRIMARY", "data": {"device_id": "hostdev0"} }
+#
+##
+{ 'event': 'UNPLUG_PRIMARY',
+  'data': { 'device_id': 'str' } }