[2/2] package/c-capnproto: require GCC 5 for C++14
diff mbox series

Message ID 20190909185215.26744-2-JoelsonCarl@gmail.com
State Accepted
Headers show
Series
  • [1/2] package/capnproto: require GCC 5 for C++14
Related show

Commit Message

Joel Carlson Sept. 9, 2019, 6:52 p.m. UTC
Adds a dependency on GCC 5 to have C++14. Since c-capnproto is useless
without having capnproto, must keep dependencies matched so you aren't
able to select c-capnproto when you can't select capnproto.

Signed-off-by: Joel Carlson <JoelsonCarl@gmail.com>
---
 package/c-capnproto/Config.in | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Patch
diff mbox series

diff --git a/package/c-capnproto/Config.in b/package/c-capnproto/Config.in
index acad5a69c8..293e4483cd 100644
--- a/package/c-capnproto/Config.in
+++ b/package/c-capnproto/Config.in
@@ -1,8 +1,8 @@ 
 config BR2_PACKAGE_C_CAPNPROTO
 	bool "c-capnproto"
 	depends on BR2_USE_MMU # capnproto
-	depends on BR2_HOST_GCC_AT_LEAST_4_8 # capnproto
-	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # capnproto
+	depends on BR2_HOST_GCC_AT_LEAST_5 # capnproto
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_5 # capnproto
 	depends on BR2_INSTALL_LIBSTDCPP # capnproto
 	depends on BR2_TOOLCHAIN_HAS_THREADS # capnproto
 	depends on BR2_TOOLCHAIN_HAS_ATOMIC # capnproto
@@ -12,10 +12,10 @@  config BR2_PACKAGE_C_CAPNPROTO
 	  plugin for C. Requires regular Cap'n Proto and only
 	  provides serialization (no RPC).
 
-comment "c-capnproto needs host and target gcc >= 4.8 w/ C++, threads, atomic"
+comment "c-capnproto needs host and target gcc >= 5 w/ C++14, threads, atomic"
 	depends on BR2_USE_MMU
-	depends on!BR2_HOST_GCC_AT_LEAST_4_8 || \
-		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 || \
+	depends on!BR2_HOST_GCC_AT_LEAST_5 || \
+		!BR2_TOOLCHAIN_GCC_AT_LEAST_5 || \
 		!BR2_INSTALL_LIBSTDCPP || \
 		!BR2_TOOLCHAIN_HAS_THREADS || \
 		!BR2_TOOLCHAIN_HAS_ATOMIC