[OpenWrt-Devel] ath79: base-files: disable sysupgrade for routerstations and ja76pf2
diff mbox series

Message ID 20190906150236.4596-1-tomek_n@o2.pl
State New
Headers show
Series
  • [OpenWrt-Devel] ath79: base-files: disable sysupgrade for routerstations and ja76pf2
Related show

Commit Message

Tomasz Maciej Nowak Sept. 6, 2019, 3:02 p.m. UTC
Previous commit 0cc87b3 "ath79: image: disable sysupgrade images for
routerstations and ja76pf2" doesn't remedy completely the posibility of
bricking the device, since user could try to downgrade with an older
image. Therefore disable sysupgrade code for these boards with a small
note.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
---
 target/linux/ath79/base-files/lib/upgrade/platform.sh | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch
diff mbox series

diff --git a/target/linux/ath79/base-files/lib/upgrade/platform.sh b/target/linux/ath79/base-files/lib/upgrade/platform.sh
index f7e62143e7..020e9fb6c1 100644
--- a/target/linux/ath79/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/base-files/lib/upgrade/platform.sh
@@ -45,11 +45,11 @@  platform_do_upgrade() {
 		redboot_fis_do_upgrade "$1" vmlinux_2
 		;;
 	jjplus,ja76pf2)
-		redboot_fis_do_upgrade "$1" linux
+		echo "Sysupgrade disabled due bug FS#2428"
 		;;
 	ubnt,routerstation|\
 	ubnt,routerstation-pro)
-		redboot_fis_do_upgrade "$1" kernel
+		echo "Sysupgrade disabled due bug FS#2428"
 		;;
 	*)
 		default_do_upgrade "$1"