[v6,1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie"
diff mbox series

Message ID 20190902034319.14026-1-xiaowei.bao@nxp.com
State Not Applicable
Headers show
Series
  • [v6,1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie"
Related show

Commit Message

Xiaowei Bao Sept. 2, 2019, 3:43 a.m. UTC
Add the PCIe compatible string for LS1028A

Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
Reviewed-by: Rob Herring <robh@kernel.org>
---
v2:
 - No change.
v3:
 - No change.
v4:
 - No change.
v5:
 - No change.
v6:
 - No change.

 Documentation/devicetree/bindings/pci/layerscape-pci.txt | 1 +
 1 file changed, 1 insertion(+)

Comments

Shawn Guo Oct. 3, 2019, 9:10 a.m. UTC | #1
On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> Add support for the LS1028a PCIe controller.
> 
> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> ---
> v2:
>  - No change.
> v3:
>  - Reuse the ls2088 driver data structurt.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/pci/controller/dwc/pci-layerscape.c b/drivers/pci/controller/dwc/pci-layerscape.c
> index 3a5fa26..f24f79a 100644
> --- a/drivers/pci/controller/dwc/pci-layerscape.c
> +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata = {
>  static const struct of_device_id ls_pcie_of_match[] = {
>  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },

I think you can save this driver change by using "fsl,ls2088a-pcie" as
compatible fallback like below.

  compatible = "fsl,ls1028a-pcie", "fsl,ls2088a-pcie";

Shawn

>  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
>  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> -- 
> 2.9.5
>
Xiaowei Bao Oct. 8, 2019, 7:11 a.m. UTC | #2
> -----Original Message-----
> From: Shawn Guo <shawnguo@kernel.org>
> Sent: 2019年10月3日 17:11
> To: Xiaowei Bao <xiaowei.bao@nxp.com>
> Cc: robh+dt@kernel.org; mark.rutland@arm.com; Leo Li
> <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai Hu
> <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> lorenzo.pieralisi@arm.com; linux-pci@vger.kernel.org;
> devicetree@vger.kernel.org; linux-kernel@vger.kernel.org;
> linux-arm-kernel@lists.infradead.org; linuxppc-dev@lists.ozlabs.org;
> bhelgaas@google.com; Z.q. Hou <zhiqiang.hou@nxp.com>
> Subject: Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> 
> On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> > Add support for the LS1028a PCIe controller.
> >
> > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > ---
> > v2:
> >  - No change.
> > v3:
> >  - Reuse the ls2088 driver data structurt.
> > v4:
> >  - No change.
> > v5:
> >  - No change.
> > v6:
> >  - No change.
> >
> >  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/drivers/pci/controller/dwc/pci-layerscape.c
> > b/drivers/pci/controller/dwc/pci-layerscape.c
> > index 3a5fa26..f24f79a 100644
> > --- a/drivers/pci/controller/dwc/pci-layerscape.c
> > +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> > @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata
> > = {  static const struct of_device_id ls_pcie_of_match[] = {
> >  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> > +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
> 
> I think you can save this driver change by using "fsl,ls2088a-pcie" as
> compatible fallback like below.
> 
>   compatible = "fsl,ls1028a-pcie", "fsl,ls2088a-pcie";

Yes, it is ok to do so, but according to the previous code, I think add a new compatible " fsl,ls1028a-pcie " to driver is better.

Thanks 
Xiaowei

> 
> Shawn
> 
> >  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
> >  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> > --
> > 2.9.5
> >

Patch
diff mbox series

diff --git a/Documentation/devicetree/bindings/pci/layerscape-pci.txt b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
index e20ceaa..99a386e 100644
--- a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
+++ b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
@@ -21,6 +21,7 @@  Required properties:
         "fsl,ls1046a-pcie"
         "fsl,ls1043a-pcie"
         "fsl,ls1012a-pcie"
+        "fsl,ls1028a-pcie"
   EP mode:
 	"fsl,ls1046a-pcie-ep", "fsl,ls-pcie-ep"
 - reg: base addresses and lengths of the PCIe controller register blocks.