[PATCH/next,2/2] package/libnice: add optional dependency to openssl
diff mbox series

Message ID 20190831130417.7725-2-bernd.kuhls@t-online.de
State New
Headers show
Series
  • [PATCH/next,1/2] package/libnice: bump version to 0.1.16
Related show

Commit Message

Bernd Kuhls Aug. 31, 2019, 1:04 p.m. UTC
Support for OpenSSL was added in version 0.1.15:
https://lists.freedesktop.org/archives/nice/2018-December/001443.html

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libnice/Config.in  |  2 +-
 package/libnice/libnice.mk | 10 +++++++++-
 2 files changed, 10 insertions(+), 2 deletions(-)

Comments

Baruch Siach Aug. 31, 2019, 8:07 p.m. UTC | #1
Hi Bernd,

On Sat, Aug 31 2019, Bernd Kuhls wrote:
> Support for OpenSSL was added in version 0.1.15:
> https://lists.freedesktop.org/archives/nice/2018-December/001443.html
>
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/libnice/Config.in  |  2 +-
>  package/libnice/libnice.mk | 10 +++++++++-
>  2 files changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/package/libnice/Config.in b/package/libnice/Config.in
> index af8e814618..1f62c0b5c8 100644
> --- a/package/libnice/Config.in
> +++ b/package/libnice/Config.in
> @@ -4,7 +4,7 @@ config BR2_PACKAGE_LIBNICE
>  	depends on BR2_USE_WCHAR # libglib2
>  	depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
>  	depends on BR2_USE_MMU # fork()
> -	select BR2_PACKAGE_GNUTLS
> +	select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_GNUTLS

Is there a reason to change the default selected crypto library from
Gnutls to Openssl?

baruch

>  	select BR2_PACKAGE_LIBGLIB2
>  	help
>  	  Libnice is an implementation of the IETF's Interactive
> diff --git a/package/libnice/libnice.mk b/package/libnice/libnice.mk
> index b2fea4d66c..4921deab33 100644
> --- a/package/libnice/libnice.mk
> +++ b/package/libnice/libnice.mk
> @@ -8,9 +8,17 @@ LIBNICE_VERSION = 0.1.16
>  LIBNICE_SITE = http://nice.freedesktop.org/releases
>  LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
>  LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
> -LIBNICE_DEPENDENCIES = gnutls libglib2 host-pkgconf
> +LIBNICE_DEPENDENCIES = libglib2 host-pkgconf
>  LIBNICE_INSTALL_STAGING = YES
>
> +ifeq ($(BR2_PACKAGE_GNUTLS),y)
> +LIBNICE_CONF_OPTS += --without-openssl
> +LIBNICE_DEPENDENCIES += gnutls
> +else
> +LIBNICE_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
> +LIBNICE_DEPENDENCIES += openssl
> +endif
> +
>  ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
>  LIBNICE_CONF_OPTS += --with-gstreamer-0.10
>  LIBNICE_DEPENDENCIES += gst-plugins-base


--
     http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch@tkos.co.il - tel: +972.52.368.4656, http://www.tkos.co.il -
Bernd Kuhls Sept. 1, 2019, 7:46 a.m. UTC | #2
Am Sat, 31 Aug 2019 23:07:35 +0300 schrieb Baruch Siach:

>> -	select BR2_PACKAGE_GNUTLS
>> +	select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_GNUTLS
> 
> Is there a reason to change the default selected crypto library from
> Gnutls to Openssl?

Hi Baruch,

yes, if

	select BR2_PACKAGE_GNUTLS if !BR2_PACKAGE_OPENSSL

is used, menuconfig throws this warning:

package/openssl/Config.in:4:error: recursive dependency detected!
package/openssl/Config.in:4:	symbol BR2_PACKAGE_OPENSSL is selected by BR2_PACKAGE_GNUTLS
package/gnutls/Config.in:1:	symbol BR2_PACKAGE_GNUTLS is selected by BR2_PACKAGE_OPENSSL

Regards, Bernd
Baruch Siach Sept. 1, 2019, 8:06 a.m. UTC | #3
Hi Bernd,

On Sun, Sep 01 2019, Bernd Kuhls wrote:
> Am Sat, 31 Aug 2019 23:07:35 +0300 schrieb Baruch Siach:
>
>>> -	select BR2_PACKAGE_GNUTLS
>>> +	select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_GNUTLS
>> 
>> Is there a reason to change the default selected crypto library from
>> Gnutls to Openssl?
>
> yes, if
>
> 	select BR2_PACKAGE_GNUTLS if !BR2_PACKAGE_OPENSSL
>
> is used, menuconfig throws this warning:
>
> package/openssl/Config.in:4:error: recursive dependency detected!
> package/openssl/Config.in:4:	symbol BR2_PACKAGE_OPENSSL is selected by BR2_PACKAGE_GNUTLS
> package/gnutls/Config.in:1:	symbol BR2_PACKAGE_GNUTLS is selected by BR2_PACKAGE_OPENSSL

I see.

I think this should be mentioned in the commit log. Especially since
Config.in defaults to openssl, while .mk defaults to gnutls.

baruch

Patch
diff mbox series

diff --git a/package/libnice/Config.in b/package/libnice/Config.in
index af8e814618..1f62c0b5c8 100644
--- a/package/libnice/Config.in
+++ b/package/libnice/Config.in
@@ -4,7 +4,7 @@  config BR2_PACKAGE_LIBNICE
 	depends on BR2_USE_WCHAR # libglib2
 	depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
 	depends on BR2_USE_MMU # fork()
-	select BR2_PACKAGE_GNUTLS
+	select BR2_PACKAGE_OPENSSL if !BR2_PACKAGE_GNUTLS
 	select BR2_PACKAGE_LIBGLIB2
 	help
 	  Libnice is an implementation of the IETF's Interactive
diff --git a/package/libnice/libnice.mk b/package/libnice/libnice.mk
index b2fea4d66c..4921deab33 100644
--- a/package/libnice/libnice.mk
+++ b/package/libnice/libnice.mk
@@ -8,9 +8,17 @@  LIBNICE_VERSION = 0.1.16
 LIBNICE_SITE = http://nice.freedesktop.org/releases
 LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
 LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
-LIBNICE_DEPENDENCIES = gnutls libglib2 host-pkgconf
+LIBNICE_DEPENDENCIES = libglib2 host-pkgconf
 LIBNICE_INSTALL_STAGING = YES
 
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+LIBNICE_CONF_OPTS += --without-openssl
+LIBNICE_DEPENDENCIES += gnutls
+else
+LIBNICE_CONF_OPTS += --with-openssl=$(STAGING_DIR)/usr
+LIBNICE_DEPENDENCIES += openssl
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE),y)
 LIBNICE_CONF_OPTS += --with-gstreamer-0.10
 LIBNICE_DEPENDENCIES += gst-plugins-base