[1/1] package/webkitgtk: fix gstreamer-gl dependency
diff mbox series

Message ID 20190807192313.118268-1-james.hilliard1@gmail.com
State New
Headers show
Series
  • [1/1] package/webkitgtk: fix gstreamer-gl dependency
Related show

Commit Message

James Hilliard Aug. 7, 2019, 7:23 p.m. UTC
The gstreamer1 opengl plugin was moved from gst1-plugins-bad to
gst1-plugins-base so we need to update webkitgtk to depend on the
correct package.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/webkitgtk/Config.in    | 3 +--
 package/webkitgtk/webkitgtk.mk | 1 -
 2 files changed, 1 insertion(+), 3 deletions(-)

Comments

Adrian Perez de Castro Aug. 7, 2019, 10:22 p.m. UTC | #1
Hi,

Thanks, this looks good to me :)

On Wed,  7 Aug 2019 13:23:13 -0600, James Hilliard <james.hilliard1@gmail.com> wrote:
> The gstreamer1 opengl plugin was moved from gst1-plugins-bad to
> gst1-plugins-base so we need to update webkitgtk to depend on the
> correct package.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>

> ---
>  package/webkitgtk/Config.in    | 3 +--
>  package/webkitgtk/webkitgtk.mk | 1 -
>  2 files changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/package/webkitgtk/Config.in b/package/webkitgtk/Config.in
> index db67c89042..d822bec06a 100644
> --- a/package/webkitgtk/Config.in
> +++ b/package/webkitgtk/Config.in
> @@ -95,8 +95,7 @@ if BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
>  config BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL
>  	bool "use gstreamer-gl"
>  	default y
> -	depends on BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
> -	select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
> +	depends on BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_OPENGL
>  	help
>  	  Use the GStreamer GL elements for handling video content.
>  	  This is recommended as it improves performance of video
> diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
> index f8cd728351..7c4a9c81f8 100644
> --- a/package/webkitgtk/webkitgtk.mk
> +++ b/package/webkitgtk/webkitgtk.mk
> @@ -88,7 +88,6 @@ endif
>  
>  ifeq ($(BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL),y)
>  WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=ON
> -WEBKITGTK_DEPENDENCIES += gst1-plugins-bad
>  else
>  WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
>  endif
> -- 
> 2.20.1
>

Patch
diff mbox series

diff --git a/package/webkitgtk/Config.in b/package/webkitgtk/Config.in
index db67c89042..d822bec06a 100644
--- a/package/webkitgtk/Config.in
+++ b/package/webkitgtk/Config.in
@@ -95,8 +95,7 @@  if BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
 config BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL
 	bool "use gstreamer-gl"
 	default y
-	depends on BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
-	select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
+	depends on BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_OPENGL
 	help
 	  Use the GStreamer GL elements for handling video content.
 	  This is recommended as it improves performance of video
diff --git a/package/webkitgtk/webkitgtk.mk b/package/webkitgtk/webkitgtk.mk
index f8cd728351..7c4a9c81f8 100644
--- a/package/webkitgtk/webkitgtk.mk
+++ b/package/webkitgtk/webkitgtk.mk
@@ -88,7 +88,6 @@  endif
 
 ifeq ($(BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL),y)
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=ON
-WEBKITGTK_DEPENDENCIES += gst1-plugins-bad
 else
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif