[linux-snap,Bionic,Xenial] Pin any PPAs to the same priority as -updates.
diff mbox series

Message ID 20190806135124.24090-1-xnox@ubuntu.com
State New
Headers show
Series
  • [linux-snap,Bionic,Xenial] Pin any PPAs to the same priority as -updates.
Related show

Commit Message

Dimitri John Ledkov Aug. 6, 2019, 1:51 p.m. UTC
PPAs only have "release" pocket, and do not have -updates, thus at the
moment they get pinned down lower than -updates. Normally, the
snappy-dev/image ppa should be treated on the same priority as
-updates.

Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>
---
 At the moment, I'm trying to build linux-snap with amd64-microcode
 package pulled in from the snappy-dev/image ppa, however, since
 linux-snap is built with proposed=true and ellaborate apt_preferences
 pinning in place, amd64-microcode is pulled in from bionic-updates,
 instead of the PPA. This fixes the issue, by elevating packages from
 the enabled PPAs to at least as high as -updates.

 Makefile | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Paolo Pisati Aug. 7, 2019, 9:28 a.m. UTC | #1
On Tue, Aug 6, 2019 at 3:51 PM Dimitri John Ledkov <xnox@ubuntu.com> wrote:
>
> PPAs only have "release" pocket, and do not have -updates, thus at the
> moment they get pinned down lower than -updates. Normally, the
> snappy-dev/image ppa should be treated on the same priority as
> -updates.
>
> Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>

Built several snaps (pc-kernel and pi-kernel) with different sets of
$PKGS - does what is says.

Acked-by: Paolo Pisati <paolo.pisati@canonical.com>
Kleber Sacilotto de Souza Aug. 7, 2019, 10:05 a.m. UTC | #2
On 06.08.19 15:51, Dimitri John Ledkov wrote:
> PPAs only have "release" pocket, and do not have -updates, thus at the
> moment they get pinned down lower than -updates. Normally, the
> snappy-dev/image ppa should be treated on the same priority as
> -updates.
> 
> Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>

Acked-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>

> ---
>  At the moment, I'm trying to build linux-snap with amd64-microcode
>  package pulled in from the snappy-dev/image ppa, however, since
>  linux-snap is built with proposed=true and ellaborate apt_preferences
>  pinning in place, amd64-microcode is pulled in from bionic-updates,
>  instead of the PPA. This fixes the issue, by elevating packages from
>  the enabled PPAs to at least as high as -updates.
> 
>  Makefile | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/Makefile b/Makefile
> index 3725b00..bb719c8 100644
> --- a/Makefile
> +++ b/Makefile
> @@ -43,6 +43,10 @@ Package: linux-*
>  Pin: release a=$(RELEASE)-proposed
>  Pin-Priority: 750
>  
> +Package: *
> +Pin: origin "ppa.launchpad.net"
> +Pin-Priority: 720
> +
>  Package: *
>  Pin: release a=$(RELEASE)-updates
>  Pin-Priority: 720
>
Paolo Pisati Aug. 7, 2019, 10:16 a.m. UTC | #3
On Wed, Aug 7, 2019 at 12:05 PM Kleber Souza <kleber.souza@canonical.com> wrote:
>
> On 06.08.19 15:51, Dimitri John Ledkov wrote:
> > PPAs only have "release" pocket, and do not have -updates, thus at the
> > moment they get pinned down lower than -updates. Normally, the
> > snappy-dev/image ppa should be treated on the same priority as
> > -updates.
> >
> > Signed-off-by: Dimitri John Ledkov <xnox@ubuntu.com>
>
> Acked-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>

Applied and pushed.

Patch
diff mbox series

diff --git a/Makefile b/Makefile
index 3725b00..bb719c8 100644
--- a/Makefile
+++ b/Makefile
@@ -43,6 +43,10 @@  Package: linux-*
 Pin: release a=$(RELEASE)-proposed
 Pin-Priority: 750
 
+Package: *
+Pin: origin "ppa.launchpad.net"
+Pin-Priority: 720
+
 Package: *
 Pin: release a=$(RELEASE)-updates
 Pin-Priority: 720