From patchwork Tue Sep 6 16:58:37 2011 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Markus Armbruster X-Patchwork-Id: 113611 Return-Path: X-Original-To: incoming@patchwork.ozlabs.org Delivered-To: patchwork-incoming@bilbo.ozlabs.org Received: from lists.gnu.org (lists.gnu.org [140.186.70.17]) (using TLSv1 with cipher AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTPS id 4FDAAB6F69 for ; Wed, 7 Sep 2011 02:59:25 +1000 (EST) Received: from localhost ([::1]:33457 helo=lists.gnu.org) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1R0yzZ-0005ca-R5 for incoming@patchwork.ozlabs.org; Tue, 06 Sep 2011 12:59:21 -0400 Received: from eggs.gnu.org ([140.186.70.92]:38053) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1R0yzN-0005bt-Ce for qemu-devel@nongnu.org; Tue, 06 Sep 2011 12:59:10 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1R0yzJ-0004Xw-Bp for qemu-devel@nongnu.org; Tue, 06 Sep 2011 12:59:09 -0400 Received: from oxygen.pond.sub.org ([78.46.104.156]:55946) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1R0yzJ-0004XL-2T for qemu-devel@nongnu.org; Tue, 06 Sep 2011 12:59:05 -0400 Received: from blackfin.pond.sub.org (p5B32C9A8.dip.t-dialin.net [91.50.201.168]) by oxygen.pond.sub.org (Postfix) with ESMTPA id CD50CA247C; Tue, 6 Sep 2011 18:59:01 +0200 (CEST) Received: by blackfin.pond.sub.org (Postfix, from userid 500) id 99BC460068; Tue, 6 Sep 2011 18:59:00 +0200 (CEST) From: Markus Armbruster To: qemu-devel@nongnu.org Date: Tue, 6 Sep 2011 18:58:37 +0200 Message-Id: <1315328340-6192-5-git-send-email-armbru@redhat.com> X-Mailer: git-send-email 1.7.6 In-Reply-To: <1315328340-6192-1-git-send-email-armbru@redhat.com> References: <1315328340-6192-1-git-send-email-armbru@redhat.com> X-detected-operating-system: by eggs.gnu.org: Genre and OS details not recognized. X-Received-From: 78.46.104.156 Cc: kwolf@redhat.com, stefano.stabellini@eu.citrix.com, lcapitulino@redhat.com, hare@suse.de, amit.shah@redhat.com, pbonzini@redhat.com, hch@lst.de Subject: [Qemu-devel] [PATCH v3 04/27] ide/atapi: Clean up misleading name in cmd_start_stop_unit() X-BeenThere: qemu-devel@nongnu.org X-Mailman-Version: 2.1.14 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org Sender: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org "eject" is misleading; it means "eject" when start is clear, but "load" when start is set. Rename to loej, because that's how MMC-5 calls it, in section 6.40. Signed-off-by: Markus Armbruster --- hw/ide/atapi.c | 8 ++++---- 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c index f38d289..cb0cdac 100644 --- a/hw/ide/atapi.c +++ b/hw/ide/atapi.c @@ -903,11 +903,11 @@ static void cmd_seek(IDEState *s, uint8_t* buf) static void cmd_start_stop_unit(IDEState *s, uint8_t* buf) { - int start, eject, sense, err = 0; - start = buf[4] & 1; - eject = (buf[4] >> 1) & 1; + int sense, err = 0; + bool start = buf[4] & 1; + bool loej = buf[4] & 2; /* load on start, eject on !start */ - if (eject) { + if (loej) { err = bdrv_eject(s->bs, !start); }