[OpenWrt-Devel,PATCHv2] toolchain: Remove powerpc64 libc restriction
diff mbox series

Message ID 20190718015740.21462-1-rosenp@gmail.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series
  • [OpenWrt-Devel,PATCHv2] toolchain: Remove powerpc64 libc restriction
Related show

Commit Message

Rosen Penev July 18, 2019, 1:57 a.m. UTC
Starting with version 1.1.15, musl supports powerpc64.

There are no known users of powerpc64 yet.

This is effectively a revert of 0de93311e1575ab6f8e9e90b5023b6fb2cedcf1f

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 v2: Add missing entries
 toolchain/Config.in | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Patch
diff mbox series

diff --git a/toolchain/Config.in b/toolchain/Config.in
index 95087b7078..faff3c8fbb 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -238,7 +238,6 @@  comment "C Library"
 choice
 	prompt "C Library implementation" if TOOLCHAINOPTS
 	default LIBC_USE_UCLIBC if arc
-	default LIBC_USE_GLIBC if powerpc64
 	default LIBC_USE_MUSL
 	help
 	  Select the C library implementation.
@@ -257,7 +256,7 @@  choice
 	config LIBC_USE_MUSL
 		select USE_MUSL
 		bool "Use musl"
-		depends on !(arc || powerpc64)
+		depends on !arc
 
 endchoice
 
@@ -275,7 +274,6 @@  config GDB
 	  Enable if you want to build the gdb.
 
 config USE_GLIBC
-	default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && (powerpc64)
 	bool
 
 config USE_UCLIBC
@@ -283,7 +281,7 @@  config USE_UCLIBC
 	bool
 
 config USE_MUSL
-	default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && !(arc || powerpc64)
+	default y if !TOOLCHAINOPTS && !EXTERNAL_TOOLCHAIN && !NATIVE_TOOLCHAIN && !(arc)
 	bool
 
 config SSP_SUPPORT