[1/1] package/libiscsi: needs threads
diff mbox series

Message ID 20190715163702.1978-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series
  • [1/1] package/libiscsi: needs threads
Related show

Commit Message

Fabrice Fontaine July 15, 2019, 4:37 p.m. UTC
threads are needed since bump to version 1.19.0 and
https://github.com/sahlberg/libiscsi/commit/41af44eba113c59dc43764d1d240397616e85b82

Fixes:
 - http://autobuild.buildroot.org/results/1d71c95378a6ef9774926bf7431c1a315e4a1b3e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libiscsi/Config.in | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Yann E. MORIN July 15, 2019, 5:05 p.m. UTC | #1
Fabrice, All,

On 2019-07-15 18:37 +0200, Fabrice Fontaine spake thusly:
> threads are needed since bump to version 1.19.0 and
> https://github.com/sahlberg/libiscsi/commit/41af44eba113c59dc43764d1d240397616e85b82
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/1d71c95378a6ef9774926bf7431c1a315e4a1b3e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/libiscsi/Config.in | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/libiscsi/Config.in b/package/libiscsi/Config.in
> index 760fecea66..1e75071476 100644
> --- a/package/libiscsi/Config.in
> +++ b/package/libiscsi/Config.in
> @@ -1,5 +1,6 @@
>  config BR2_PACKAGE_LIBISCSI
>  	bool "libiscsi"
> +	depends on BR2_TOOLCHAIN_HAS_THREADS
>  	help
>  	  Libiscsi is a client-side library to implement the iSCSI
>  	  protocol that can be used to access resource of an iSCSI
> @@ -10,3 +11,6 @@ config BR2_PACKAGE_LIBISCSI
>  	  for simpler applications.
>  
>  	  https://github.com/sahlberg/libiscsi  (no proper homepage)
> +
> +comment "libiscsi needs a toolchain w/ threads"
> +	depends on !BR2_TOOLCHAIN_HAS_THREADS
> -- 
> 2.20.1
>
Thomas Petazzoni July 17, 2019, 5:39 a.m. UTC | #2
On Mon, 15 Jul 2019 18:37:02 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> threads are needed since bump to version 1.19.0 and
> https://github.com/sahlberg/libiscsi/commit/41af44eba113c59dc43764d1d240397616e85b82
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/1d71c95378a6ef9774926bf7431c1a315e4a1b3e
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libiscsi/Config.in | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to master, thanks.

Thomas

Patch
diff mbox series

diff --git a/package/libiscsi/Config.in b/package/libiscsi/Config.in
index 760fecea66..1e75071476 100644
--- a/package/libiscsi/Config.in
+++ b/package/libiscsi/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_LIBISCSI
 	bool "libiscsi"
+	depends on BR2_TOOLCHAIN_HAS_THREADS
 	help
 	  Libiscsi is a client-side library to implement the iSCSI
 	  protocol that can be used to access resource of an iSCSI
@@ -10,3 +11,6 @@  config BR2_PACKAGE_LIBISCSI
 	  for simpler applications.
 
 	  https://github.com/sahlberg/libiscsi  (no proper homepage)
+
+comment "libiscsi needs a toolchain w/ threads"
+	depends on !BR2_TOOLCHAIN_HAS_THREADS