[U-Boot,PATCHv2,10/11] spi: Kconfig: Mark LPC32XX_SSP as DEPRECATED
diff mbox series

Message ID 1558273931-1415-10-git-send-email-trini@konsulko.com
State Superseded
Delegated to: Tom Rini
Headers show
Series
  • [U-Boot,PATCHv2,01/11] configs: Migrate CONFIG_FMAN_ETH and some related options to Kconfig
Related show

Commit Message

Tom Rini May 19, 2019, 1:52 p.m. UTC
From: Jagan Teki <jagan@amarulasolutions.com>

Mark LPC32XX_SSP as DEPRECATED, this so the resulting build shows
warning for deprecated configuration enabled and associated code
will remove in v2019.07 release.

Cc: Albert ARIBAUD <albert.aribaud@3adev.fr>
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
Acked-by: Vladimir Zapolskiy <vz@mleia.com>
Acked-by: Sylvain Lemieux <slemieux@tycoint.com>
[trini: Switch to DEPRECATED]
Signed-off-by: Tom Rini <trini@konsulko.com>
---
 drivers/spi/Kconfig | 1 +
 1 file changed, 1 insertion(+)

Patch
diff mbox series

diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
index 201a4d970a95..cd92b0d44895 100644
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -364,6 +364,7 @@  config KIRKWOOD_SPI
 
 config LPC32XX_SSP
 	bool "LPC32XX SPI Driver"
+	depends on DEPRECATED
 	help
 	  Enable support for SPI on LPC32xx