[U-Boot,PATCHv2,07/11] spi: Kconfig: Mark SH_SPI as DEPRECATED
diff mbox series

Message ID 1558273931-1415-7-git-send-email-trini@konsulko.com
State Superseded
Delegated to: Tom Rini
Headers show
Series
  • [U-Boot,PATCHv2,01/11] configs: Migrate CONFIG_FMAN_ETH and some related options to Kconfig
Related show

Commit Message

Tom Rini May 19, 2019, 1:52 p.m. UTC
From: Jagan Teki <jagan@amarulasolutions.com>

Mark SH_SPI as DEPRECATED, this so the resulting build shows
warning for a deprecated configuration enabled and associated code
will remove in v2019.07 release.

Cc: Marek Vasut <marex@denx.de>
Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
[trini: Switch to DEPRECATED]
Signed-off-by: Tom Rini <trini@konsulko.com>
---
 drivers/spi/Kconfig | 1 +
 1 file changed, 1 insertion(+)

Comments

Marek Vasut May 19, 2019, 4:21 p.m. UTC | #1
On 5/19/19 3:52 PM, Tom Rini wrote:
> From: Jagan Teki <jagan@amarulasolutions.com>
> 
> Mark SH_SPI as DEPRECATED, this so the resulting build shows
> warning for a deprecated configuration enabled and associated code
> will remove in v2019.07 release.
> 
> Cc: Marek Vasut <marex@denx.de>
> Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
> [trini: Switch to DEPRECATED]
> Signed-off-by: Tom Rini <trini@konsulko.com>

Acked-by: Marek Vasut <marek.vasut@gmail.com>

> ---
>  drivers/spi/Kconfig | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
> index 3c345f108498..9aac500bb187 100644
> --- a/drivers/spi/Kconfig
> +++ b/drivers/spi/Kconfig
> @@ -343,6 +343,7 @@ config DAVINCI_SPI
>  
>  config SH_SPI
>  	bool "SuperH SPI driver"
> +	depends on DEPRECATED
>  	help
>  	  Enable the SuperH SPI controller driver. This driver can be used
>  	  on various SuperH SoCs, such as SH7757.
>

Patch
diff mbox series

diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
index 3c345f108498..9aac500bb187 100644
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -343,6 +343,7 @@  config DAVINCI_SPI
 
 config SH_SPI
 	bool "SuperH SPI driver"
+	depends on DEPRECATED
 	help
 	  Enable the SuperH SPI controller driver. This driver can be used
 	  on various SuperH SoCs, such as SH7757.