Patchwork [2/2] UBUNTU: Turn off the OMAP2_DSS_DSI support

login
register
mail settings
Submitter Stefan Bader
Date Aug. 12, 2011, 6:22 p.m.
Message ID <1313173370-6231-3-git-send-email-stefan.bader@canonical.com>
Download mbox | patch
Permalink /patch/109881/
State New
Headers show

Comments

Stefan Bader - Aug. 12, 2011, 6:22 p.m.
This seems to cause crashes when enabled on omap4 without
an SDI panel (regulator errors).

BugLink: http://bugs.launchpad.net/bugs/720055

Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
---
 debian.ti-omap4/config/config.common.ubuntu |    3 +--
 1 files changed, 1 insertions(+), 2 deletions(-)
Dechesne, Nicolas - Aug. 12, 2011, 10:45 p.m.
On Fri, Aug 12, 2011 at 8:22 PM, Stefan Bader <stefan.bader@canonical.com>wrote:

> This seems to cause crashes when enabled on omap4 without
> an SDI panel (regulator errors).
>
> BugLink: http://bugs.launchpad.net/bugs/720055
>
> Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
>

i seem to see this a bit too late... but i would have prefer to NACK this.
this config is useful for OMAP4 boards with embedded DSI displays (such as
TI Blaze that we intend to support with oneiric:
http://omappedia.org/wiki/OMAP4_Blaze). i agree the name is misleading as it
has OMAP2 in it.. in fact there was a 'break through' in the h/w arch
between the OMAP1 familiy and the OMAP2, but OMAP3 and OMAP4 are sharing
some IPs so some 'OMAP2' name still mean something useful on OMAP3 and
OMAP4.

so we will need to investigate the failure and get that enabled eventually.
we will try to reproduce and provide the proper patches.
Tim Gardner - Aug. 15, 2011, 1:01 p.m.
On 08/12/2011 04:45 PM, Dechesne, Nicolas wrote:
>
>
> On Fri, Aug 12, 2011 at 8:22 PM, Stefan Bader
> <stefan.bader@canonical.com <mailto:stefan.bader@canonical.com>> wrote:
>
>     This seems to cause crashes when enabled on omap4 without
>     an SDI panel (regulator errors).
>
>     BugLink: http://bugs.launchpad.net/bugs/720055
>
>     Signed-off-by: Stefan Bader <stefan.bader@canonical.com
>     <mailto:stefan.bader@canonical.com>>
>
>
> i seem to see this a bit too late... but i would have prefer to NACK
> this. this config is useful for OMAP4 boards with embedded DSI displays
> (such as TI Blaze that we intend to support with oneiric:
> http://omappedia.org/wiki/OMAP4_Blaze). i agree the name is misleading
> as it has OMAP2 in it.. in fact there was a 'break through' in the h/w
> arch between the OMAP1 familiy and the OMAP2, but OMAP3 and OMAP4 are
> sharing some IPs so some 'OMAP2' name still mean something useful on
> OMAP3 and OMAP4.
>
> so we will need to investigate the failure and get that enabled
> eventually. we will try to reproduce and provide the proper patches.
>

Paolo - there is a linux-ti-omap4 3.0.0-1201.4 built and in the archive. 
Do you want to change this config setting before updating the meta package ?

rtg
Stefan Bader - Aug. 16, 2011, 7:47 a.m.
On 13.08.2011 00:45, Dechesne, Nicolas wrote:
> On Fri, Aug 12, 2011 at 8:22 PM, Stefan Bader <stefan.bader@canonical.com>wrote:
> 
>> This seems to cause crashes when enabled on omap4 without
>> an SDI panel (regulator errors).
>>
>> BugLink: http://bugs.launchpad.net/bugs/720055
>>
>> Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
>>
> 
> i seem to see this a bit too late... but i would have prefer to NACK this.
> this config is useful for OMAP4 boards with embedded DSI displays (such as
> TI Blaze that we intend to support with oneiric:
> http://omappedia.org/wiki/OMAP4_Blaze). i agree the name is misleading as it
> has OMAP2 in it.. in fact there was a 'break through' in the h/w arch
> between the OMAP1 familiy and the OMAP2, but OMAP3 and OMAP4 are sharing
> some IPs so some 'OMAP2' name still mean something useful on OMAP3 and
> OMAP4.
> 
> so we will need to investigate the failure and get that enabled eventually.
> we will try to reproduce and provide the proper patches.
> 

I also had hoped this one to stay in review a bit longer. Mostly because this
was something that only happened once, during an upgrade. And after DISPC going
mad in the syslog before. Just that there was this bug report that seemed to
match the one we saw quite well.
But of course, we had not the whole picture of supported boards. So Paolo, feel
free to get this enabled again.

-Stefan
Paolo Pisati - Aug. 16, 2011, 8:23 a.m.
On 08/16/2011 09:47 AM, Stefan Bader wrote:
> 
> I also had hoped this one to stay in review a bit longer. Mostly because this
> was something that only happened once, during an upgrade. And after DISPC going
> mad in the syslog before. Just that there was this bug report that seemed to
> match the one we saw quite well.
> But of course, we had not the whole picture of supported boards. So Paolo, feel
> free to get this enabled again.

Ok, so Tim can you revert 73fe8dd ("UBUNTU: Turn off the OMAP2_DSS_DSI
support")? I would like to see if we can reproduce it some more.
Tim Gardner - Aug. 16, 2011, 2:41 p.m.
On 08/16/2011 02:23 AM, Paolo Pisati wrote:
> On 08/16/2011 09:47 AM, Stefan Bader wrote:
>>
>> I also had hoped this one to stay in review a bit longer. Mostly because this
>> was something that only happened once, during an upgrade. And after DISPC going
>> mad in the syslog before. Just that there was this bug report that seemed to
>> match the one we saw quite well.
>> But of course, we had not the whole picture of supported boards. So Paolo, feel
>> free to get this enabled again.
>
> Ok, so Tim can you revert 73fe8dd ("UBUNTU: Turn off the OMAP2_DSS_DSI
> support")? I would like to see if we can reproduce it some more.
>

Done. uploaded linux-ti-omap4_3.0.0-1201.5

Patch

diff --git a/debian.ti-omap4/config/config.common.ubuntu b/debian.ti-omap4/config/config.common.ubuntu
index 766dfe5a..983c2f3 100644
--- a/debian.ti-omap4/config/config.common.ubuntu
+++ b/debian.ti-omap4/config/config.common.ubuntu
@@ -2106,7 +2106,7 @@  CONFIG_OMAP2_DSS=y
 # CONFIG_OMAP2_DSS_COLLECT_IRQ_STATS is not set
 CONFIG_OMAP2_DSS_DEBUG_SUPPORT=y
 CONFIG_OMAP2_DSS_DPI=y
-CONFIG_OMAP2_DSS_DSI=y
+# CONFIG_OMAP2_DSS_DSI is not set
 CONFIG_OMAP2_DSS_FAKE_VSYNC=y
 CONFIG_OMAP2_DSS_MIN_FCK_PER_PCK=0
 # CONFIG_OMAP2_DSS_RFBI is not set
@@ -2161,7 +2161,6 @@  CONFIG_PANEL_GENERIC_DPI=y
 CONFIG_PANEL_PARPORT=0
 CONFIG_PANEL_PROFILE=5
 # CONFIG_PANEL_SHARP_LS037V7DW01 is not set
-CONFIG_PANEL_TAAL=y
 # CONFIG_PANEL_TPO_TD043MTEA1 is not set
 CONFIG_PANTHERLORD_FF=y
 CONFIG_PARPORT=m