[1/2] package/libupnp18: needs host-pkgconf
diff mbox series

Message ID 20190509110438.31340-1-joerg.krause@embedded.rocks
State Accepted
Headers show
Series
  • [1/2] package/libupnp18: needs host-pkgconf
Related show

Commit Message

Jörg Krause May 9, 2019, 11:04 a.m. UTC
Otherwise build fails with:

```
configure.ac:630: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
```

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
 package/libupnp18/libupnp18.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 18, 2019, 9:32 p.m. UTC | #1
On Thu,  9 May 2019 13:04:37 +0200
Jörg Krause <joerg.krause@embedded.rocks> wrote:

> Otherwise build fails with:
> 
> ```
> configure.ac:630: error: possibly undefined macro: AC_MSG_ERROR
>       If this token and others are legitimate, please use m4_pattern_allow.
> ```
> 

You forgot to add a reference to the autobuilder failure that this
commit fixes, so I've added it and applied to master. Thanks!

Thomas
Peter Korsgaard June 6, 2019, 7:35 a.m. UTC | #2
>>>>> "Jörg" == Jörg Krause <joerg.krause@embedded.rocks> writes:

 > Otherwise build fails with:
 > ```
 > configure.ac:630: error: possibly undefined macro: AC_MSG_ERROR
 >       If this token and others are legitimate, please use m4_pattern_allow.
 > ```

 > Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>

Committed to 2019.02.x, thanks.

Patch
diff mbox series

diff --git a/package/libupnp18/libupnp18.mk b/package/libupnp18/libupnp18.mk
index 5154be5316..35e8dc4a47 100644
--- a/package/libupnp18/libupnp18.mk
+++ b/package/libupnp18/libupnp18.mk
@@ -11,12 +11,13 @@  LIBUPNP18_CONF_ENV = ac_cv_lib_compat_ftime=no
 LIBUPNP18_INSTALL_STAGING = YES
 LIBUPNP18_LICENSE = BSD-3-Clause
 LIBUPNP18_LICENSE_FILES = COPYING
+LIBUPNP18_DEPENDENCIES = host-pkgconf
 # We're patching configure.ac
 LIBUPNP18_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBUPNP18_CONF_OPTS += --enable-open-ssl
-LIBUPNP18_DEPENDENCIES += host-pkgconf openssl
+LIBUPNP18_DEPENDENCIES += openssl
 else
 LIBUPNP18_CONF_OPTS += --disable-open-ssl
 endif