Patchwork [04/11] Document CLooG-ISL requirement for Graphite

login
register
mail settings
Submitter Sebastian Pop
Date Aug. 11, 2011, 10:44 p.m.
Message ID <1313102679-32012-5-git-send-email-sebpop@gmail.com>
Download mbox | patch
Permalink /patch/109698/
State New
Headers show

Comments

Sebastian Pop - Aug. 11, 2011, 10:44 p.m.
2011-07-26  Sebastian Pop  <sebastian.pop@amd.com>

        * doc/invoke.texi: Document CLooG-ISL requirement for Graphite.

Signed-off-by: Sebastian Pop <sebpop@gmail.com>
---
 gcc/doc/install.texi |   24 ++++++++----------------
 1 files changed, 8 insertions(+), 16 deletions(-)

Patch

diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
index 9b1b037..368221f 100644
--- a/gcc/doc/install.texi
+++ b/gcc/doc/install.texi
@@ -365,26 +365,18 @@  distribution is found in a subdirectory of your GCC sources named
 Necessary to build GCC with the Graphite loop optimizations.
 It can be downloaded from @uref{http://www.cs.unipr.it/ppl/Download/}.
 
-The @option{--with-ppl} configure option should be used if PPL is not
+The configure option @option{--with-ppl} should be used if PPL is not
 installed in your default library search path.
 
-@item CLooG-PPL version 0.15 or CLooG 0.16
+@item CLooG-ISL 0.16
 
-Necessary to build GCC with the Graphite loop optimizations.  There
-are two versions available.  CLooG-PPL 0.15 as well as CLooG 0.16.
-The former is the default right now.  It can be downloaded from
-@uref{ftp://gcc.gnu.org/pub/gcc/infrastructure/} as
-@file{cloog-ppl-0.15.tar.gz}.
+Necessary to build GCC with the Graphite loop optimizations.  It is
+available from @uref{ftp://gcc.gnu.org/pub/gcc/infrastructure/} as
+@file{cloog-0.16.3.tar.gz}.  Even if CLooG 0.16 does not use PPL, PPL
+is still required for Graphite.
 
-CLooG 0.16 support is still in testing stage, but will be the
-default in future GCC releases.  It is also available at
-@uref{ftp://gcc.gnu.org/pub/gcc/infrastructure/} as
-@file{cloog-0.16.1.tar.gz}.  To use it add the additional configure
-option @option{--enable-cloog-backend=isl}.  Even if CLooG 0.16
-does not use PPL, PPL is still required for Graphite.
-
-In both cases @option{--with-cloog} configure option should be used
-if CLooG is not installed in your default library search path.
+The configure option @option{--with-cloog} should be used if CLooG is
+not installed in your default library search path.
 
 @end table