Use Linux 5.1 in build-many-glibcs.py [committed]
diff mbox series

Message ID alpine.DEB.2.21.1905071449500.3445@digraph.polyomino.org.uk
State New
Headers show
Series
  • Use Linux 5.1 in build-many-glibcs.py [committed]
Related show

Commit Message

Joseph Myers May 7, 2019, 2:50 p.m. UTC
Committed.

Comments

Joseph Myers May 7, 2019, 10:48 p.m. UTC | #1
I've now reverted this patch.

Linux 5.1 headers are not in fact usable for glibc testing, because
"[PATCH] uapi: avoid namespace conflict in linux/posix_types.h"
<https://lore.kernel.org/lkml/20190319165123.3967889-1-arnd@arndb.de/>
did not get merged for 5.1 and so many conform/ tests fail.

We'll need to await a fix for that issue reaching a Linux kernel release, 
or the issue otherwise somehow being worked around in glibc, before we can 
use kernel headers newer than 5.0.

Patch
diff mbox series

diff --git a/ChangeLog b/ChangeLog
index 1ddb948fa8..692af8e5c2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@ 
 2019-05-07  Joseph Myers  <joseph@codesourcery.com>
 
+	* scripts/build-many-glibcs.py (Context.checkout): Default Linux
+	version to 5.1.
+
 	* scripts/build-many-glibcs.py (Context.checkout): Default GCC
 	version to 9 branch.
 
diff --git a/scripts/build-many-glibcs.py b/scripts/build-many-glibcs.py
index 6f9a35331f..5f7db23f26 100755
--- a/scripts/build-many-glibcs.py
+++ b/scripts/build-many-glibcs.py
@@ -714,7 +714,7 @@  class Context(object):
                             'gcc': 'vcs-9',
                             'glibc': 'vcs-mainline',
                             'gmp': '6.1.2',
-                            'linux': '5.0',
+                            'linux': '5.1',
                             'mpc': '1.1.0',
                             'mpfr': '4.0.2',
                             'mig': 'vcs-mainline',