From patchwork Wed Aug 3 13:07:48 2011 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Markus Armbruster X-Patchwork-Id: 108255 Return-Path: X-Original-To: incoming@patchwork.ozlabs.org Delivered-To: patchwork-incoming@bilbo.ozlabs.org Received: from lists.gnu.org (lists.gnu.org [140.186.70.17]) (using TLSv1 with cipher AES256-SHA (256/256 bits)) (Client did not present a certificate) by ozlabs.org (Postfix) with ESMTPS id 78BF3B71D5 for ; Thu, 4 Aug 2011 01:01:58 +1000 (EST) Received: from localhost ([::1]:49256 helo=lists.gnu.org) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1QobCy-00041U-Dy for incoming@patchwork.ozlabs.org; Wed, 03 Aug 2011 09:10:00 -0400 Received: from eggs.gnu.org ([140.186.70.92]:47432) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1QobBd-0000R3-UT for qemu-devel@nongnu.org; Wed, 03 Aug 2011 09:08:39 -0400 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1QobBV-00019b-HQ for qemu-devel@nongnu.org; Wed, 03 Aug 2011 09:08:37 -0400 Received: from oxygen.pond.sub.org ([78.46.104.156]:52259) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1QobBV-000193-A5 for qemu-devel@nongnu.org; Wed, 03 Aug 2011 09:08:29 -0400 Received: from blackfin.pond.sub.org (p5B32D904.dip.t-dialin.net [91.50.217.4]) by oxygen.pond.sub.org (Postfix) with ESMTPA id 2EE99A2C92; Wed, 3 Aug 2011 15:08:27 +0200 (CEST) Received: by blackfin.pond.sub.org (Postfix, from userid 500) id E819260055; Wed, 3 Aug 2011 15:08:24 +0200 (CEST) From: Markus Armbruster To: qemu-devel@nongnu.org Date: Wed, 3 Aug 2011 15:07:48 +0200 Message-Id: <1312376904-16115-10-git-send-email-armbru@redhat.com> X-Mailer: git-send-email 1.7.6 In-Reply-To: <1312376904-16115-1-git-send-email-armbru@redhat.com> References: <1312376904-16115-1-git-send-email-armbru@redhat.com> X-detected-operating-system: by eggs.gnu.org: Genre and OS details not recognized. X-Received-From: 78.46.104.156 Cc: kwolf@redhat.com, quintela@redhat.com, stefano.stabellini@eu.citrix.com, lcapitulino@redhat.com, hare@suse.de, amit.shah@redhat.com, hch@lst.de Subject: [Qemu-devel] [PATCH v2 09/45] ide/atapi: Clean up misleading name in cmd_start_stop_unit() X-BeenThere: qemu-devel@nongnu.org X-Mailman-Version: 2.1.14 Precedence: list List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org Sender: qemu-devel-bounces+incoming=patchwork.ozlabs.org@nongnu.org "eject" is misleading; it means "eject" when start is clear, but "load" when start is set. Rename to loej, because that's how MMC-5 calls it, in section 6.40. Signed-off-by: Markus Armbruster --- hw/ide/atapi.c | 8 ++++---- 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c index fe2fb0b..17fbef8 100644 --- a/hw/ide/atapi.c +++ b/hw/ide/atapi.c @@ -892,11 +892,11 @@ static void cmd_seek(IDEState *s, uint8_t* buf) static void cmd_start_stop_unit(IDEState *s, uint8_t* buf) { - int start, eject, sense, err = 0; - start = buf[4] & 1; - eject = (buf[4] >> 1) & 1; + int sense, err = 0; + bool start = buf[4] & 1; + bool loej = buf[4] & 2; - if (eject) { + if (loej) { err = bdrv_eject(s->bs, !start); }