Patchwork [v2,09/45] ide/atapi: Clean up misleading name in cmd_start_stop_unit()

login
register
mail settings
Submitter Markus Armbruster
Date Aug. 3, 2011, 1:07 p.m.
Message ID <1312376904-16115-10-git-send-email-armbru@redhat.com>
Download mbox | patch
Permalink /patch/108255/
State New
Headers show

Comments

Markus Armbruster - Aug. 3, 2011, 1:07 p.m.
"eject" is misleading; it means "eject" when start is clear, but
"load" when start is set.  Rename to loej, because that's how MMC-5
calls it, in section 6.40.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 hw/ide/atapi.c |    8 ++++----
 1 files changed, 4 insertions(+), 4 deletions(-)
Kevin Wolf - Sept. 2, 2011, 10:20 a.m.
Am 03.08.2011 15:07, schrieb Markus Armbruster:
> "eject" is misleading; it means "eject" when start is clear, but
> "load" when start is set.  Rename to loej, because that's how MMC-5
> calls it, in section 6.40.
> 
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>  hw/ide/atapi.c |    8 ++++----
>  1 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
> index fe2fb0b..17fbef8 100644
> --- a/hw/ide/atapi.c
> +++ b/hw/ide/atapi.c
> @@ -892,11 +892,11 @@ static void cmd_seek(IDEState *s, uint8_t* buf)
>  
>  static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
>  {
> -    int start, eject, sense, err = 0;
> -    start = buf[4] & 1;
> -    eject = (buf[4] >> 1) & 1;
> +    int sense, err = 0;
> +    bool start = buf[4] & 1;
> +    bool loej = buf[4] & 2;
>  
> -    if (eject) {
> +    if (loej) {
>          err = bdrv_eject(s->bs, !start);
>      }
>  

"eject" has the advantage that I immediately know that it's something to
do with the tray. "loej" on the other hand is a sequence of four random
characters. Maybe add a comment?

Kevin
Markus Armbruster - Sept. 2, 2011, 2:47 p.m.
Kevin Wolf <kwolf@redhat.com> writes:

> Am 03.08.2011 15:07, schrieb Markus Armbruster:
>> "eject" is misleading; it means "eject" when start is clear, but
>> "load" when start is set.  Rename to loej, because that's how MMC-5
>> calls it, in section 6.40.
>> 
>> Signed-off-by: Markus Armbruster <armbru@redhat.com>
>> ---
>>  hw/ide/atapi.c |    8 ++++----
>>  1 files changed, 4 insertions(+), 4 deletions(-)
>> 
>> diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
>> index fe2fb0b..17fbef8 100644
>> --- a/hw/ide/atapi.c
>> +++ b/hw/ide/atapi.c
>> @@ -892,11 +892,11 @@ static void cmd_seek(IDEState *s, uint8_t* buf)
>>  
>>  static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
>>  {
>> -    int start, eject, sense, err = 0;
>> -    start = buf[4] & 1;
>> -    eject = (buf[4] >> 1) & 1;
>> +    int sense, err = 0;
>> +    bool start = buf[4] & 1;
>> +    bool loej = buf[4] & 2;
>>  
>> -    if (eject) {
>> +    if (loej) {
>>          err = bdrv_eject(s->bs, !start);
>>      }
>>  
>
> "eject" has the advantage that I immediately know that it's something to
> do with the tray. "loej" on the other hand is a sequence of four random
> characters. Maybe add a comment?

The name "loej" comes from MMC-5.  I can add a comment to its
definition.

Patch

diff --git a/hw/ide/atapi.c b/hw/ide/atapi.c
index fe2fb0b..17fbef8 100644
--- a/hw/ide/atapi.c
+++ b/hw/ide/atapi.c
@@ -892,11 +892,11 @@  static void cmd_seek(IDEState *s, uint8_t* buf)
 
 static void cmd_start_stop_unit(IDEState *s, uint8_t* buf)
 {
-    int start, eject, sense, err = 0;
-    start = buf[4] & 1;
-    eject = (buf[4] >> 1) & 1;
+    int sense, err = 0;
+    bool start = buf[4] & 1;
+    bool loej = buf[4] & 2;
 
-    if (eject) {
+    if (loej) {
         err = bdrv_eject(s->bs, !start);
     }