Patchwork [v8,1/5] coroutine: add gthread dependency

login
register
mail settings
Submitter Stefan Hajnoczi
Date July 26, 2011, 9:21 a.m.
Message ID <1311672077-4592-2-git-send-email-stefanha@linux.vnet.ibm.com>
Download mbox | patch
Permalink /patch/106810/
State New
Headers show

Comments

Stefan Hajnoczi - July 26, 2011, 9:21 a.m.
Commit 1fc7bd4a86a2bfeafcec29445871eb97469a2699 removed the gthread and
gio dependency since qemu-ga did not require it.  Coroutines require
gthread, so add it back in.

Signed-off-by: Stefan Hajnoczi <stefanha@linux.vnet.ibm.com>
---
 configure |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

Patch

diff --git a/configure b/configure
index 600da9b..5150372 100755
--- a/configure
+++ b/configure
@@ -1811,9 +1811,9 @@  fi
 
 ##########################################
 # glib support probe
-if $pkg_config --modversion glib-2.0 > /dev/null 2>&1 ; then
-    glib_cflags=`$pkg_config --cflags glib-2.0 2>/dev/null`
-    glib_libs=`$pkg_config --libs glib-2.0 2>/dev/null`
+if $pkg_config --modversion gthread-2.0 > /dev/null 2>&1 ; then
+    glib_cflags=`$pkg_config --cflags gthread-2.0 2>/dev/null`
+    glib_libs=`$pkg_config --libs gthread-2.0 2>/dev/null`
     libs_softmmu="$glib_libs $libs_softmmu"
     libs_tools="$glib_libs $libs_tools"
 else