Patchwork [2/3] Require cloog 0.16.3

login
register
mail settings
Submitter Tobias Grosser
Date July 21, 2011, 11 p.m.
Message ID <aa4929aba5acb228a53b645e367476c1003a741b.1311289011.git.tobias@grosser.es>
Download mbox | patch
Permalink /patch/106184/
State New
Headers show

Comments

Tobias Grosser - July 21, 2011, 11 p.m.
2011-07-21  Tobias Grosser  <tobias@grosser.es>

	* configure: Regenerated.
	* configure.ac: Require cloog isl 0.16.3
---
 ChangeLog    |    5 +++++
 configure    |    6 +++---
 configure.ac |    2 +-
 3 files changed, 9 insertions(+), 4 deletions(-)
Sebastian Pop - Aug. 2, 2011, 3:47 p.m.
Ping.

Could one of the configure maintainers review these changes?

Thanks,
Sebastian


On Thu, Jul 21, 2011 at 18:00, Tobias Grosser <tobias@grosser.es> wrote:
> 2011-07-21  Tobias Grosser  <tobias@grosser.es>
>
>        * configure: Regenerated.
>        * configure.ac: Require cloog isl 0.16.3
> ---
>  ChangeLog    |    5 +++++
>  configure    |    6 +++---
>  configure.ac |    2 +-
>  3 files changed, 9 insertions(+), 4 deletions(-)
>
> diff --git a/ChangeLog b/ChangeLog
> index a08a780..3d83bd2 100644
> --- a/ChangeLog
> +++ b/ChangeLog
> @@ -1,6 +1,11 @@
>  2011-07-21  Tobias Grosser  <tobias@grosser.es>
>
>        * configure: Regenerated.
> +       * configure.ac: Require cloog isl 0.16.3
> +
> +2011-07-21  Tobias Grosser  <tobias@grosser.es>
> +
> +       * configure: Regenerated.
>        * config/cloog.m4: Remove support for CLooG-ppl and CLooG-parma,
>        both cloog.org and legacy versions. The only supported version will
>        be CLooG with the isl backend.
> diff --git a/configure b/configure
> index 6608b86..57f099b 100755
> --- a/configure
> +++ b/configure
> @@ -5834,8 +5834,8 @@ $as_echo "$gcc_cv_cloog_type" >&6; }
>     CFLAGS="${_cloog_saved_CFLAGS} ${clooginc} ${pplinc} ${gmpinc}"
>     LDFLAGS="${_cloog_saved_LDFLAGS} ${clooglibs} ${ppllibs}"
>
> -    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.1 of CLooG" >&5
> -$as_echo_n "checking for version 0.16.1 of CLooG... " >&6; }
> +    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.3 of CLooG" >&5
> +$as_echo_n "checking for version 0.16.3 of CLooG... " >&6; }
>  if test "${gcc_cv_cloog+set}" = set; then :
>   $as_echo_n "(cached) " >&6
>  else
> @@ -5847,7 +5847,7 @@ main ()
>  {
>  #if CLOOG_VERSION_MAJOR != 0 \
>     || CLOOG_VERSION_MINOR != 16 \
> -    || CLOOG_VERSION_REVISION < 1
> +    || CLOOG_VERSION_REVISION < 3
>     choke me
>    #endif
>   ;
> diff --git a/configure.ac b/configure.ac
> index e64e577..00325a1 100644
> --- a/configure.ac
> +++ b/configure.ac
> @@ -1588,7 +1588,7 @@ if test "x$with_cloog" != "xno"; then
>   dnl
>   dnl If we use CLooG-Legacy, the provided version information is
>   dnl ignored.
> -  CLOOG_CHECK_VERSION(0,16,1)
> +  CLOOG_CHECK_VERSION(0,16,3)
>
>   dnl Only execute fail-action, if CLooG has been requested.
>   CLOOG_IF_FAILED([
> --
> 1.7.4.1
>
>
Tobias Grosser - Aug. 10, 2011, 10:05 p.m.
On 08/02/2011 04:47 PM, Sebastian Pop wrote:
> Ping.
>
> Could one of the configure maintainers review these changes?

Ping II.

This is needed for move to the official cloog.org library interface [1].

Thanks a lot for your time
Tobi

[1] http://gcc.gnu.org/ml/gcc-patches/2011-08/msg00976.html

> Thanks,
> Sebastian
>
>
> On Thu, Jul 21, 2011 at 18:00, Tobias Grosser<tobias@grosser.es>  wrote:
>> 2011-07-21  Tobias Grosser<tobias@grosser.es>
>>
>>         * configure: Regenerated.
>>         * configure.ac: Require cloog isl 0.16.3
>> ---
>>   ChangeLog    |    5 +++++
>>   configure    |    6 +++---
>>   configure.ac |    2 +-
>>   3 files changed, 9 insertions(+), 4 deletions(-)
>>
>> diff --git a/ChangeLog b/ChangeLog
>> index a08a780..3d83bd2 100644
>> --- a/ChangeLog
>> +++ b/ChangeLog
>> @@ -1,6 +1,11 @@
>>   2011-07-21  Tobias Grosser<tobias@grosser.es>
>>
>>         * configure: Regenerated.
>> +       * configure.ac: Require cloog isl 0.16.3
>> +
>> +2011-07-21  Tobias Grosser<tobias@grosser.es>
>> +
>> +       * configure: Regenerated.
>>         * config/cloog.m4: Remove support for CLooG-ppl and CLooG-parma,
>>         both cloog.org and legacy versions. The only supported version will
>>         be CLooG with the isl backend.
>> diff --git a/configure b/configure
>> index 6608b86..57f099b 100755
>> --- a/configure
>> +++ b/configure
>> @@ -5834,8 +5834,8 @@ $as_echo "$gcc_cv_cloog_type">&6; }
>>      CFLAGS="${_cloog_saved_CFLAGS} ${clooginc} ${pplinc} ${gmpinc}"
>>      LDFLAGS="${_cloog_saved_LDFLAGS} ${clooglibs} ${ppllibs}"
>>
>> -    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.1 of CLooG">&5
>> -$as_echo_n "checking for version 0.16.1 of CLooG... ">&6; }
>> +    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.3 of CLooG">&5
>> +$as_echo_n "checking for version 0.16.3 of CLooG... ">&6; }
>>   if test "${gcc_cv_cloog+set}" = set; then :
>>    $as_echo_n "(cached) ">&6
>>   else
>> @@ -5847,7 +5847,7 @@ main ()
>>   {
>>   #if CLOOG_VERSION_MAJOR != 0 \
>>      || CLOOG_VERSION_MINOR != 16 \
>> -    || CLOOG_VERSION_REVISION<  1
>> +    || CLOOG_VERSION_REVISION<  3
>>      choke me
>>     #endif
>>    ;
>> diff --git a/configure.ac b/configure.ac
>> index e64e577..00325a1 100644
>> --- a/configure.ac
>> +++ b/configure.ac
>> @@ -1588,7 +1588,7 @@ if test "x$with_cloog" != "xno"; then
>>    dnl
>>    dnl If we use CLooG-Legacy, the provided version information is
>>    dnl ignored.
>> -  CLOOG_CHECK_VERSION(0,16,1)
>> +  CLOOG_CHECK_VERSION(0,16,3)
>>
>>    dnl Only execute fail-action, if CLooG has been requested.
>>    CLOOG_IF_FAILED([
>> --
>> 1.7.4.1
>>
>>

Patch

diff --git a/ChangeLog b/ChangeLog
index a08a780..3d83bd2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,11 @@ 
 2011-07-21  Tobias Grosser  <tobias@grosser.es>
 
 	* configure: Regenerated.
+	* configure.ac: Require cloog isl 0.16.3
+
+2011-07-21  Tobias Grosser  <tobias@grosser.es>
+
+	* configure: Regenerated.
 	* config/cloog.m4: Remove support for CLooG-ppl and CLooG-parma,
 	both cloog.org and legacy versions. The only supported version will
 	be CLooG with the isl backend.
diff --git a/configure b/configure
index 6608b86..57f099b 100755
--- a/configure
+++ b/configure
@@ -5834,8 +5834,8 @@  $as_echo "$gcc_cv_cloog_type" >&6; }
     CFLAGS="${_cloog_saved_CFLAGS} ${clooginc} ${pplinc} ${gmpinc}"
     LDFLAGS="${_cloog_saved_LDFLAGS} ${clooglibs} ${ppllibs}"
 
-    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.1 of CLooG" >&5
-$as_echo_n "checking for version 0.16.1 of CLooG... " >&6; }
+    { $as_echo "$as_me:${as_lineno-$LINENO}: checking for version 0.16.3 of CLooG" >&5
+$as_echo_n "checking for version 0.16.3 of CLooG... " >&6; }
 if test "${gcc_cv_cloog+set}" = set; then :
   $as_echo_n "(cached) " >&6
 else
@@ -5847,7 +5847,7 @@  main ()
 {
 #if CLOOG_VERSION_MAJOR != 0 \
     || CLOOG_VERSION_MINOR != 16 \
-    || CLOOG_VERSION_REVISION < 1
+    || CLOOG_VERSION_REVISION < 3
     choke me
    #endif
   ;
diff --git a/configure.ac b/configure.ac
index e64e577..00325a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1588,7 +1588,7 @@  if test "x$with_cloog" != "xno"; then
   dnl
   dnl If we use CLooG-Legacy, the provided version information is
   dnl ignored.
-  CLOOG_CHECK_VERSION(0,16,1)
+  CLOOG_CHECK_VERSION(0,16,3)
 
   dnl Only execute fail-action, if CLooG has been requested.
   CLOOG_IF_FAILED([