diff mbox

safe unordered local iterators

Message ID 4E26A2EE.4020209@oracle.com
State New
Headers show

Commit Message

Paolo Carlini July 20, 2011, 9:42 a.m. UTC
On 07/20/2011 10:51 AM, Jonathan Wakely wrote:
> On 20 July 2011 09:38, Jonathan Wakely wrote:
>> See http://gcc.gnu.org/ml/gcc/2011-07/msg00368.html
>>
>> Should code inside namespace __gnu_debug be using std::size_t instead
>> of assuming ::size_t has been declared?
>>
> Or maybe that use (which is the only unqualified size_t I see in
> include/debug/* outside of namespace std) should be using size_type
> anyway.
Indeed. I applied the below, to resolve this pressing issue, Jonathan 
will hopefully provide soon feedback about the naming issue.

Paolo.

/////////////////////
2011-07-20  Paolo Carlini  <paolo.carlini@oracle.com>

	* include/debug/safe_local_iterator.h (_Safe_local_iterator<>::
	_Safe_local_iterator(const _Iterator&, size_type, const _Sequence*)):
	Fix typo.

Comments

Paolo Carlini July 20, 2011, 9:45 a.m. UTC | #1
On 07/20/2011 11:42 AM, Paolo Carlini wrote:
> On 07/20/2011 10:51 AM, Jonathan Wakely wrote:
>> On 20 July 2011 09:38, Jonathan Wakely wrote:
>>> See http://gcc.gnu.org/ml/gcc/2011-07/msg00368.html
>>>
>>> Should code inside namespace __gnu_debug be using std::size_t instead
>>> of assuming ::size_t has been declared?
>>>
>> Or maybe that use (which is the only unqualified size_t I see in
>> include/debug/* outside of namespace std) should be using size_type
>> anyway.
> Indeed. I applied the below, to resolve this pressing issue, Jonathan 
> will hopefully provide soon feedback about the naming issue.
I meant Francois of course ;)

Paolo.
diff mbox

Patch

Index: include/debug/safe_local_iterator.h
===================================================================
--- include/debug/safe_local_iterator.h	(revision 176499)
+++ include/debug/safe_local_iterator.h	(working copy)
@@ -88,7 +88,7 @@ 
        * @pre @p seq is not NULL
        * @post this is not singular
        */
-      _Safe_local_iterator(const _Iterator& __i, size_t __bucket,
+      _Safe_local_iterator(const _Iterator& __i, size_type __bucket,
 			   const _Sequence* __seq)
       : _Safe_local_iterator_base(__seq, _M_constant()), _M_current(__i),
 	_M_bucket(__bucket)