[5/8,v2] support/graph-depends: also cut on host-gzip
diff mbox series

Message ID 54a5230dcc7d087c93c86805a89a3652b4fca09c.1551608168.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series
  • [1/8,v2] support/graph-depends: make sure mandatory deps are displayed
Related show

Commit Message

Yann E. MORIN March 3, 2019, 10:16 a.m. UTC
When host-gzip is needed, it is a mandatory dependency of all packages.
As such, drawing the dependency lines toward host-gzip would uselessly
clutter the graph.

So, like for the skeleton, host-skeleton, and host-tar, we cut the
dependency chains toward host-gzip.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 support/scripts/graph-depends | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch
diff mbox series

diff --git a/support/scripts/graph-depends b/support/scripts/graph-depends
index 3143c61cc4..29134c8237 100755
--- a/support/scripts/graph-depends
+++ b/support/scripts/graph-depends
@@ -172,7 +172,7 @@  def remove_transitive_deps(pkg, deps):
 
 # List of dependencies that all/many packages have, and that we want
 # to trim when generating the dependency graph.
-MANDATORY_DEPS = ['toolchain', 'skeleton', 'host-skeleton', 'host-tar']
+MANDATORY_DEPS = ['toolchain', 'skeleton', 'host-skeleton', 'host-tar', 'host-gzip']
 
 
 # This function removes the dependency on some 'mandatory' package, like the