[SRU,trusty,linux-meta,1/1] UBUNTU: fix depedency on -extra packages

Message ID 20190211122002.14411-2-kleber.souza@canonical.com
State New
Headers show
Series
  • Follow up fixes for LP: #1764794
Related show

Commit Message

Kleber Souza Feb. 11, 2019, 12:20 p.m.
BugLink: http://bugs.launchpad.net/bugs/1764794

Previous commit "UBUNTU: switch to signed-only binary packages" was
missing the dependency update from linux-image-extra to
linux-modules-extra, which is now the package which ships the extra
modules.

Signed-off-by: Kleber Sacilotto de Souza <kleber.souza@canonical.com>
---
 debian/control.d/generic | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/debian/control.d/generic b/debian/control.d/generic
index 692c47e..7628506 100644
--- a/debian/control.d/generic
+++ b/debian/control.d/generic
@@ -11,7 +11,7 @@  Package: linux-image-generic
 Architecture: i386 amd64 armhf arm64 ppc64el
 Section: kernel
 Priority: optional
-Depends: ${misc:Depends}, linux-image-${kernel-abi-version}-generic | linux-image-unsigned-${kernel-abi-version}-generic, linux-image-extra-${kernel-abi-version}-generic [i386 amd64 ppc64el], linux-firmware, intel-microcode [amd64 i386], amd64-microcode [amd64 i386]
+Depends: ${misc:Depends}, linux-image-${kernel-abi-version}-generic | linux-image-unsigned-${kernel-abi-version}-generic, linux-modules-extra-${kernel-abi-version}-generic [i386 amd64 ppc64el], linux-firmware, intel-microcode [amd64 i386], amd64-microcode [amd64 i386]
 Description: Generic Linux kernel image
  This package will always depend on the latest generic kernel image
  available.