Patchwork fix WOL on 2nd port on i350

login
register
mail settings
Submitter Martin Wilck
Date July 4, 2011, 2:17 p.m.
Message ID <4E11CB87.5040806@ts.fujitsu.com>
Download mbox | patch
Permalink /patch/103112/
State Awaiting Upstream
Delegated to: David Miller
Headers show

Comments

Martin Wilck - July 4, 2011, 2:17 p.m.
WOL fails on second port of a i350 network adapter with the latest
upstream kernel driver. It works with the sf.net driver 3.0.19. The
following patch seems to be missing upstream.

Regards,
Martin
Jeff Kirsher - July 6, 2011, 8:53 a.m.
On Mon, Jul 4, 2011 at 07:17, Martin Wilck <martin.wilck@ts.fujitsu.com> wrote:
> WOL fails on second port of a i350 network adapter with the latest
> upstream kernel driver. It works with the sf.net driver 3.0.19. The
> following patch seems to be missing upstream.
>
> Regards,
> Martin
>
> --
> Dr. Martin Wilck
> PRIMERGY System Software Engineer
> x86 Server Engineering
>
> FUJITSU
> Fujitsu Technology Solutions GmbH
> Heinz-Nixdorf-Ring 1
> 33106 Paderborn, Germany
> Phone:                  ++49 5251 525 2796
> Fax:                    ++49 5251 525 2820
> Email:                  martin.wilck@ts.fujitsu.com
> Internet:               http://ts.fujitsu.com
> Company Details:        http://ts.fujitsu.com/imprint
>
>

Thanks, we should have a patch to sync up the upstream driver in
net-next (3.1) here soon.

Patch

--- linus/drivers/net/igb/igb_main.c	2011-06-13 00:17:28.000000000 +0200
+++ linus/drivers/net/igb/igb_main.c.new	2011-07-04 14:24:00.000000000 +0200
@@ -1985,7 +1985,7 @@  static int __devinit igb_probe(struct pc
 
 	if (hw->bus.func == 0)
 		hw->nvm.ops.read(hw, NVM_INIT_CONTROL3_PORT_A, 1, &eeprom_data);
-	else if (hw->mac.type == e1000_82580)
+	else if (hw->mac.type >= e1000_82580)
 		hw->nvm.ops.read(hw, NVM_INIT_CONTROL3_PORT_A +
 		                 NVM_82580_LAN_FUNC_OFFSET(hw->bus.func), 1,
 		                 &eeprom_data);