Patchwork [build,doc] Obsolete IRIX 6.5, Tru64 UNIX V5.1

login
register
mail settings
Submitter Rainer Orth
Date July 1, 2011, 11:27 a.m.
Message ID <yddtyb6utpj.fsf@manam.CeBiTec.Uni-Bielefeld.DE>
Download mbox | patch
Permalink /patch/102896/
State New
Headers show

Comments

Rainer Orth - July 1, 2011, 11:27 a.m.
"Joseph S. Myers" <joseph@codesourcery.com> writes:

> On Fri, 1 Jul 2011, Rainer Orth wrote:
>
>> 2011-04-08  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>
>> 
>> 	* config.gcc: Obsolete alpha*-dec-osf5.1, mips-sgi-irix6.5.
>> 	* doc/install.texi (Specific, alpha*-dec-osf5.1): Document it.
>> 	(Specific, mips-sgi-irix6): Likewise.
>
> contrib/config-list.mk should also be updated to append 
> OPT-enable-obsolete to the relevant target names.

Done as follows.  Untested, but patterned exactly after the other
entries.

	Rainer


2011-07-01  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>

	* config-list.mk (LIST): Append OPT-enable-obsolete to
	alpha-dec-osf5.1, mips-sgi-irix6.5.

Patch

Index: contrib/config-list.mk
===================================================================
--- contrib/config-list.mk	(revision 175753)
+++ contrib/config-list.mk	(working copy)
@@ -12,7 +12,8 @@ 
 #
 # v850e1-elf is rejected by config.sub
 LIST = alpha-linux-gnu alpha-freebsd6 alpha-netbsd alpha-openbsd \
-  alpha-dec-osf5.1 alpha64-dec-vms alpha-dec-vms am33_2.0-linux \
+  alpha-dec-osf5.1OPT-enable-obsolete alpha64-dec-vms alpha-dec-vms \
+  am33_2.0-linux \
   arm-wrs-vxworks arm-freebsd6 arm-netbsdelf arm-linux \
   arm-linux-androideabi arm-uclinux_eabi arm-ecos-elf arm-eabi \
   arm-symbianelf arm-rtems arm-elf arm-wince-pe avr-rtems avr-elf \
@@ -35,7 +36,8 @@ 
   m32r-linux m32rle-linux m68k-elf m68k-netbsdelf \
   m68k-openbsd m68k-uclinux m68k-linux m68k-rtems \
   mcore-elf mep-elf microblaze-linux microblaze-elf \
-  mips-sgi-irix6.5OPT-with-stabsOPT-enable-threads=posix mips-netbsd \
+  mips-sgi-irix6.5OPT-with-stabsOPT-enable-threads=posixOPT-enable-obsolete \
+  mips-netbsd \
   mips64el-st-linux-gnu mips64octeon-linux mipsisa64r2-linux \
   mipsisa32r2-linux-gnu mips-openbsd mipsisa64r2-sde-elf mipsisa32-elfoabi \
   mipsisa64-elfoabi mipsisa64r2el-elf mipsisa64sr71k-elf mipsisa64sb1-elf \