Patchwork [build,doc] Obsolete IRIX 6.5, Tru64 UNIX V5.1

login
register
mail settings
Submitter Rainer Orth
Date July 1, 2011, 9:25 a.m.
Message ID <ydd4o36xsgq.fsf@manam.CeBiTec.Uni-Bielefeld.DE>
Download mbox | patch
Permalink /patch/102885/
State New
Headers show

Comments

Rainer Orth - July 1, 2011, 9:25 a.m.
I think the time has come to obsolete the IRIX 6.5 and Tru64 UNIX V5.1
ports: my test machines are falling apart one by one, bootstraps take
between 24 (osf) and 36 (irix) hours, and both platform's EOSL is
approaching:

* IRIX 6.5 until December 2013:

  http://www.sgi.com/support/services/irix_mips_support.html

* Tru64 UNIX V5.1B until December 2012:

  http://tru64unix.compaq.com/tru64roadmap.pdf
  http://h30097.www3.hp.com/pdf/FINAL_Tru64UNIX_Policy_Page_24March2009.pdf
  http://h30097.www3.hp.com/external_letter_2010.pdf

Given that there is not to be much user demand, this seems
reasonable.  I'm currently making a pass over the remaining testsuite
failures and PRs to get 4.7 into as good shape as possible on both
platforms.

Tested by configuring without and with --enable-obsolete on
alpha-dec-osf5.1b, installed on mainline.

I will update gcc-4.7/changes.html with this change and the removal of
-compat-bsd on Solaris soon.

	Rainer


2011-04-08  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>

	* config.gcc: Obsolete alpha*-dec-osf5.1, mips-sgi-irix6.5.
	* doc/install.texi (Specific, alpha*-dec-osf5.1): Document it.
	(Specific, mips-sgi-irix6): Likewise.
Joseph S. Myers - July 1, 2011, 11:19 a.m.
On Fri, 1 Jul 2011, Rainer Orth wrote:

> 2011-04-08  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>
> 
> 	* config.gcc: Obsolete alpha*-dec-osf5.1, mips-sgi-irix6.5.
> 	* doc/install.texi (Specific, alpha*-dec-osf5.1): Document it.
> 	(Specific, mips-sgi-irix6): Likewise.

contrib/config-list.mk should also be updated to append 
OPT-enable-obsolete to the relevant target names.

Patch

diff --git a/gcc/config.gcc b/gcc/config.gcc
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
@@ -237,7 +237,9 @@  md_file=
 
 # Obsolete configurations.
 case ${target} in
-   i[34567]86-*-interix3*		\
+   alpha*-dec-osf5.1*			\
+ | i[34567]86-*-interix3*		\
+ | mips-sgi-irix6.5			\
  | mips*-*-openbsd*			\
  | score-*				\
  | *-*-solaris2.8*			\
diff --git a/gcc/doc/install.texi b/gcc/doc/install.texi
--- a/gcc/doc/install.texi
+++ b/gcc/doc/install.texi
@@ -3086,10 +3086,12 @@  Systems using processors that implement 
 are running the DEC/Compaq/HP Unix (DEC OSF/1, Digital UNIX, or Compaq/HP
 Tru64 UNIX) operating system, for example the DEC Alpha AXP systems.
 
-As of GCC 3.2, versions before @code{alpha*-dec-osf4} are no longer
-supported.  (These are the versions which identify themselves as DEC
-OSF/1.)  As of GCC 4.6, support for Tru64 UNIX V4.0 and V5.0 has been
-removed.
+Support for Tru64 UNIX V5.1 has been obsoleted in GCC 4.7, but can still
+be enabled by configuring with @option{--enable-obsolete}.  Support will
+be removed in GCC 4.8.  As of GCC 4.6, support for Tru64 UNIX V4.0 and
+V5.0 has been removed.  As of GCC 3.2, versions before
+@code{alpha*-dec-osf4} are no longer supported.  (These are the versions
+which identify themselves as DEC OSF/1.)
 
 On Tru64 UNIX, virtual memory exhausted bootstrap failures
 may be fixed by reconfiguring Kernel Virtual Memory and Swap parameters
@@ -3868,11 +3870,13 @@  Support for IRIX 5 has been removed in G
 @end html
 @heading @anchor{mips-sgi-irix6}mips-sgi-irix6
 
-Support for IRIX 6 releases before 6.5 has been removed in GCC 4.6, as
-well as support for
-the O32 ABI.  It is @emph{strongly} recommended to upgrade to at least
-IRIX 6.5.18.  This release introduced full ISO C99 support, though for
-the N32 and N64 ABIs only.
+Support for IRIX 6.5 has been obsoleted in GCC 4.7, but can still be
+enabled by configuring with @option{--enable-obsolete}.  Support will be
+removed in GCC 4.8.  Support for IRIX 6 releases before 6.5 has been
+removed in GCC 4.6, as well as support for the O32 ABI.  It is
+@emph{strongly} recommended to upgrade to at least IRIX 6.5.18.  This
+release introduced full ISO C99 support, though for the N32 and N64 ABIs
+only.
 
 To build and use GCC on IRIX 6.5, you need the IRIX Development Foundation
 (IDF) and IRIX Development Libraries (IDL).  They are included with the