[PULL,5/9] Travis CI: make specified Python versions usable on jobs
diff mbox series

Message ID 20190117201743.20470-6-ehabkost@redhat.com
State New
Headers show
Series
  • [PULL,1/9] scripts/device-crash-test: Remove known crashes
Related show

Commit Message

Eduardo Habkost Jan. 17, 2019, 8:17 p.m. UTC
From: Cleber Rosa <crosa@redhat.com>

For the two Python jobs, which seem to have the goal of making sure
QEMU builds successfully on the 3.0-3.6 spectrum of Python 3 versions,
the specified version is only applicable if a Python virtual
environment is used.  To do that, it's necessary to define the
(primary?) language of the job to be Python.

Also, Travis doesn't have a 3.0 Python installation available for the
chosen distro, 3.4 being the lower version available.

Reference: https://docs.travis-ci.com/user/languages/python/#specifying-python-versions
Signed-off-by: Cleber Rosa <crosa@redhat.com>
Message-Id: <20181109150710.31085-4-crosa@redhat.com>
Reviewed-by: Alex Bennée <alex.bennee@linaro.org>
[ehabkost: Now 3.4 is the lowest Python version available]
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>

fixup! Travis CI: make specified Python versions usable on jobs

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
 .travis.yml | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Patch
diff mbox series

diff --git a/.travis.yml b/.travis.yml
index 93fd0164a0..87d9fa971c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -175,12 +175,14 @@  matrix:
     # Python builds
     - env:
         - CONFIG="--target-list=x86_64-softmmu"
+      language: python
       python:
-        - "3.0"
+        - "3.4"
 
 
     - env:
         - CONFIG="--target-list=x86_64-softmmu"
+      language: python
       python:
         - "3.6"