[testsuite] Require lto support in g++.dg/torture/pr48954.C

Submitted by Rainer Orth on June 14, 2011, 1:43 p.m.

Details

Message ID ydd8vt47cm3.fsf@manam.CeBiTec.Uni-Bielefeld.DE
State New
Headers show

Commit Message

Rainer Orth June 14, 2011, 1:43 p.m.
The new g++.dg/torture/pr48954.C testcase FAILs on alpha-dec-osf5.1b:

FAIL: g++.dg/torture/pr48954.C  -O0  (test for excess errors)
Excess errors:
cc1plus: error: LTO support has not been enabled in this configuration

The following test fixes this, tested with the appropriate runtest
invocation, installed on mainline.

	Rainer


2011-06-14  Rainer Orth  <ro@CeBiTec.Uni-Bielefeld.DE>

	* g++.dg/torture/pr48954.C: Use dg-require-effective-target lto.

Patch hide | download patch | download mbox

Index: gcc/testsuite/g++.dg/torture/pr48954.C
===================================================================
--- gcc/testsuite/g++.dg/torture/pr48954.C	(revision 175018)
+++ gcc/testsuite/g++.dg/torture/pr48954.C	(working copy)
@@ -1,5 +1,7 @@ 
 /* { dg-do compile } */
 /* { dg-options "-O2 -flto -fno-early-inlining -fkeep-inline-functions" } */
+/* { dg-require-effective-target lto } */
+
 struct A
 {
   virtual void foo () = 0;