mbox series

[ovs-dev,v5,0/6] netdev-dpdk: Fix management of pre-existing mempools.

Message ID 1507737656-31627-1-git-send-email-antonio.fischetti@intel.com
Headers show
Series netdev-dpdk: Fix management of pre-existing mempools. | expand

Message

Fischetti, Antonio Oct. 11, 2017, 4 p.m. UTC
List of versions:
 - v5: manage new MTU value when a pre-existing mempool is returned.
 - v4: fix NUMA awareness usecase
 - v3: avoid deletion of pre-existing mempools
 - v2: rework to accomodate code changes for dpdk ports too
 - v1: 1st implementation.

Fischetti, Antonio (6):
  netdev-dpdk: fix management of pre-existing mempools.
  netdev-dpdk: Fix mempool names to reflect socket id.
  netdev-dpdk: skip init for existing mempools.
  netdev-dpdk: assert mempool names.
  netdev-dpdk: Reword mp_size as n_mbufs.
  netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.

 lib/netdev-dpdk.c | 88 +++++++++++++++++++++++++++++++------------------------
 1 file changed, 50 insertions(+), 38 deletions(-)

Comments

Mark Kavanagh Oct. 13, 2017, 2:46 p.m. UTC | #1
>From: ovs-dev-bounces@openvswitch.org [mailto:ovs-dev-bounces@openvswitch.org]
>On Behalf Of antonio.fischetti@intel.com
>Sent: Wednesday, October 11, 2017 5:01 PM
>To: dev@openvswitch.org
>Subject: [ovs-dev] [PATCH v5 0/6] netdev-dpdk: Fix management of pre-existing
>mempools.
>
>List of versions:
> - v5: manage new MTU value when a pre-existing mempool is returned.
> - v4: fix NUMA awareness usecase
> - v3: avoid deletion of pre-existing mempools
> - v2: rework to accomodate code changes for dpdk ports too
> - v1: 1st implementation.
>
>Fischetti, Antonio (6):
>  netdev-dpdk: fix management of pre-existing mempools.
>  netdev-dpdk: Fix mempool names to reflect socket id.
>  netdev-dpdk: skip init for existing mempools.
>  netdev-dpdk: assert mempool names.
>  netdev-dpdk: Reword mp_size as n_mbufs.
>  netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.

Hi Antonio,

Some general comments on this patchset:
- patches 1 and 3 of the series should be squashed into one.
- patches 3-6 are purely cosmetic, and do not contribute to fixing the mempool reconfiguration mechanism;
  as such, they should be part of a separate patchset.
- initial testing has been successful; I'll send on final results as soon as they are available.

Thanks,
Mark


>
> lib/netdev-dpdk.c | 88 +++++++++++++++++++++++++++++++-----------------------
>-
> 1 file changed, 50 insertions(+), 38 deletions(-)
>
>--
>2.4.11
>
>_______________________________________________
>dev mailing list
>dev@openvswitch.org
>https://mail.openvswitch.org/mailman/listinfo/ovs-dev
Fischetti, Antonio Oct. 13, 2017, 5:55 p.m. UTC | #2
Thanks Mark for your review, some comment inline.

-Antonio

> -----Original Message-----
> From: Kavanagh, Mark B
> Sent: Friday, October 13, 2017 3:46 PM
> To: Fischetti, Antonio <antonio.fischetti@intel.com>; dev@openvswitch.org
> Subject: RE: [ovs-dev] [PATCH v5 0/6] netdev-dpdk: Fix management of pre-
> existing mempools.
> 
> 
> 
> >From: ovs-dev-bounces@openvswitch.org [mailto:ovs-dev-bounces@openvswitch.org]
> >On Behalf Of antonio.fischetti@intel.com
> >Sent: Wednesday, October 11, 2017 5:01 PM
> >To: dev@openvswitch.org
> >Subject: [ovs-dev] [PATCH v5 0/6] netdev-dpdk: Fix management of pre-existing
> >mempools.
> >
> >List of versions:
> > - v5: manage new MTU value when a pre-existing mempool is returned.
> > - v4: fix NUMA awareness usecase
> > - v3: avoid deletion of pre-existing mempools
> > - v2: rework to accomodate code changes for dpdk ports too
> > - v1: 1st implementation.
> >
> >Fischetti, Antonio (6):
> >  netdev-dpdk: fix management of pre-existing mempools.
> >  netdev-dpdk: Fix mempool names to reflect socket id.
> >  netdev-dpdk: skip init for existing mempools.
> >  netdev-dpdk: assert mempool names.
> >  netdev-dpdk: Reword mp_size as n_mbufs.
> >  netdev-dpdk: Rename dpdk_mp_put as dpdk_mp_free.
> 
> Hi Antonio,
> 
> Some general comments on this patchset:
> - patches 1 and 3 of the series should be squashed into one.

[Antonio] 
The fixes are for two different issues:
 - Issue #1: detecting when previous mempools must be released
 - Issue #2: mempool name generation for NUMA-awareness test case 

The 1st issue came earlier from a PVP test case and while its fix 
was being tested, the 2nd issue for 	the NUMA-awareness usecase 
came later on. I kept these two fixes into two separate
patches because the vHost Zero-copy development was blocked 
by the issue #1, so keeping two independent patches would speed
up upstreaming patch #1 - and unblocking vHost Zero-copy 
development.


> - patches 3-6 are purely cosmetic, and do not contribute to fixing the mempool
> reconfiguration mechanism;

[Antonio] Agree, the name of the series says "Fix management.."
but the real 'fixes' are in patches #1 and #2.


>   as such, they should be part of a separate patchset.
> - initial testing has been successful; I'll send on final results as soon as
> they are available.
> 
> Thanks,
> Mark
> 
> 
> >
> > lib/netdev-dpdk.c | 88 +++++++++++++++++++++++++++++++-----------------------
> >-
> > 1 file changed, 50 insertions(+), 38 deletions(-)
> >
> >--
> >2.4.11
> >
> >_______________________________________________
> >dev mailing list
> >dev@openvswitch.org
> >https://mail.openvswitch.org/mailman/listinfo/ovs-dev